Edgewall Software
Modify

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#9402 closed defect (duplicate)

Invalid links in TitleIndex macro with hierarchy format

Reported by: Itamar Ostricher Owned by: Christian Boos
Priority: normal Milestone:
Component: wiki system Version: 0.12dev
Severity: normal Keywords: TitleIndex
Cc: leho@…, hazen@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Instead of explaining, I'll simply provide an example.

Usage:

[[TitleIndex(TracDev/,format=hierarchy)]]

(see the complete output below)

Notice the ApiChanges bullet. It looks something like:

What I would expect is:

Complete macro output:

Attachments (0)

Change History (6)

comment:1 by Christian Boos, 12 years ago

Keywords: TitleIndex added
Milestone: 0.12.1
Owner: set to Christian Boos

Thanks for the test case. I have indeed a few pending changes in that area that fix a few problems reported earlier (by Mark Mc Mahon on #8925 and on Trac-dev).

comment:2 by lkraav <leho@…>, 12 years ago

Cc: leho@… added

comment:3 by Christian Boos, 11 years ago

Milestone: 0.12.1next-minor-0.12.x

Not for 0.12.1.

comment:4 by hazen@…, 11 years ago

Cc: hazen@… added

comment:5 by Thijs Triemstra, 11 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #8925

comment:6 by Remy Blank, 11 years ago

Milestone: next-minor-0.12.x

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.