Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#2716 closed defect (duplicate)

TicketQuery macro does not strike-through closed tickets

Reported by: stephane Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I just used the TicketQuery macro the first time and discovered this small bug.

See the example below:

Normal result

[[TicketQuery(milestone=0.9.4&status=closed)]]

#1038
Support custom milestone ordering.
#1064
sort version combo descending in new ticket form
#1150
Version/Milestone 0.10 is sorted before 0.9.0 in comboboxes
#2006
broken images and attachments. SSL related.
#2253
RSS for Custom Query should include the constraints as a query string in the channel link
#2324
global trac.ini settings don't work consistently
#2330
summary href URL not correctly rendered if not t.id in the query
#2408
Email notification to reporters is broken
#2430
Milestone progess bars don't fill their bounding box
#2431
Custom Query fails with Custom Field containing a hyphen (-)
#2459
Safari: adding filter to Custom Query renders the page incorrectly
#2481
"Permission list [user]" command show wrong format information
#2485
trac-admin resync crash
#2536
Can't use proper names as logins
#2544
Objects in the 'textwidget' CSS class do not change border color upon focus
#2583
Not markuped "Ticket details" on timeline
#2606
Custom queries use a custom field's name instead of its label as column name
#2613
Error in deleting a report
#2621
pretty_size(size) fails if size == 512
#2664
TicketQuery should display closed ticket links with line-through style (like compact view)
#2666
Image URL in Timeline RSS feed invalid
#2680
Templates directory order for ClearSilver to read from when project index page was requested
#2706
Problem with custom query sort when all filters are removed
#2707
String index out of range
#2735
Roadmap iCalendar tasks lack due date.

Compact result

[[TicketQuery(milestone=0.9.4&status=closed,compact)]]

#1038, #1064, #1150, #2006, #2253, #2324, #2330, #2408, #2430, #2431, #2459, #2481, #2485, #2536, #2544, #2583, #2606, #2613, #2621, #2664, #2666, #2680, #2706, #2707, #2735

Attachments (0)

Change History (5)

comment:1 by markus, 16 years ago

Milestone: 0.9.4
Resolution: duplicate
Status: newclosed

Dupe of #2664.

comment:2 by stephane, 16 years ago

Hmmm youre right!

But I went first to

http://projects.edgewall.com/trac/search

and searched for TicketQuery

But it didnt find any ticket with "TicketQuery" and so I thought I am the first one.

  • Is this a bug in the search module?
  • Is it already known?

Please tell me if I should file this as a defect :-)

comment:3 by markus, 16 years ago

Stephane,

the search module does not always work reliable. This is a well known bug; you don't have to file it once more. ;-)

comment:4 by Christian Boos, 16 years ago

? No, it's not that it's not reliable … that would indeed be a bug. Rather, searching for a wiki-cased word goes through the Quick Jump facility and goes to the TicketQuery wiki page directly.

In this situation, one needs to prefix the Wiki page name by "!" or a space, e.g. search:!TicketQuery or search:" TicketQuery".

Note that the above 2 links shows the existence of a (minor) bug: when using the first form, the highlighted term will be "TicketQuery".

comment:5 by markus, 16 years ago

?

My fault, I was mainly referring to #2129 that already has been fixed a while back. Sorry for the confusion.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.