Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#2459 closed defect (fixed)

Safari: adding filter to Custom Query renders the page incorrectly

Reported by: anonymous Owned by: Christopher Lenz
Priority: normal Milestone: 0.9.4
Component: ticket system Version: 0.9.2
Severity: normal Keywords: layout query
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christopher Lenz)

To reproduce:

  1. select "Custom Query" in "View Tickets"
  2. choose item "Summary" from the "Add filter" drop-down list
  3. the page will be displayed incorrectly (the Summary filter will be added underneath the existing Status filter, see the attached screenshot)
  4. click the "Update" button renders the page properly

Tested in Trac 0.92 (projects.edgewall.com), Safari 2.0.2 (build 416.13)

Attachments (1)

Untitled.png (204.3 KB ) - added by anonymous 14 years ago.
The same page displays correctly in Firefox 1.5.

Download all attachments as: .zip

Change History (8)

by anonymous, 14 years ago

Attachment: Untitled.png added

The same page displays correctly in Firefox 1.5.

comment:1 by Christopher Lenz, 14 years ago

Component: generalticket system
Keywords: layout query added

I believe this is actually a bug in Web Kit, and have unfortunately not found a workaround as of yet.

comment:2 by erik@…, 14 years ago

This was fixed in the osx 10.4.4 update.

comment:3 by Kevin Ballard <kevin@…>, 14 years ago

No it was not. I'm running 10.4.4 right now and I still have this issue.

comment:4 by anonymous, 14 years ago

Has anyone reported the problem to the Webkit team at http://webkit.opendarwin.org/quality/reporting.html? They probably will need a reduced test case that shows the issue, too.

comment:5 by erik@…, 14 years ago

Sorry, I hadn't realized exactly how the bug appeared. It looks like it only happens when you attempt to insert before the first element of the table. As a lame workaround that I just stuck in my trac server, you can add an 'empty' tbody at the beginning of the table in the query.cs template. This renders a blank line at the beginning of the table, but at least it works.

'empty tbody':

<tbody><tr><td></td></tr></tbody>

comment:6 by Christopher Lenz, 14 years ago

Description: modified (diff)
Milestone: 0.9.4
Owner: changed from Jonas Borgström to Christopher Lenz
Status: newassigned

Yeah, that works. Thanks!

comment:7 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: assignedclosed

Fixed in [2890] and [2893].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.