Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#11914 closed task (fixed)

Release Trac 1.0.5 / 1.1.4

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.0.5
Component: general Version:
Severity: normal Keywords: release
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Ryan J Ollos)

This ticket is used to coordinate the finalization and testing of the next stable version of Trac, 1.0.5, and the next developer-stable version of Trac, 1.1.4. Some proposed dates:

  • Feb 23rd: Stop development on stable branches and trunk and start the testing and release cycle.
  • Mar 2nd: Release Trac 1.0.5 / 1.1.4

Attachments (0)

Change History (31)

comment:1 by figaro, 7 years ago

Type: defecttask

Changing to task.

comment:2 by Ryan J Ollos, 7 years ago

Summary: Release Trac 0.12.7 / 1.0.4 / 1.1.4Release Trac 0.12.7 / 1.0.5 / 1.1.4

1.0.4 will be released soon with a fix for #11930.

comment:3 by Ryan J Ollos, 7 years ago

Milestone: 1.0.41.0.5

comment:4 by Ryan J Ollos, 7 years ago

Last edited 7 years ago by Ryan J Ollos (previous) (diff)

comment:5 by Ryan J Ollos, 7 years ago

Description: modified (diff)
Summary: Release Trac 0.12.7 / 1.0.5 / 1.1.4Release Trac 1.0.5 / 1.1.4

#11954 is the ticket for release of 0.12.7.

in reply to:  4 comment:6 by Ryan J Ollos, 7 years ago

Replying to rjollos:

DONE include TicketQuery page in default-pages (comment:9:ticket:11725).

Wiki edited in TracQuery@44 and TicketQuery@13. Next, TicketQuery needs to be added to default-pages. We should consider first renaming the page to TracTicketQueryMacro.

Last edited 7 years ago by Ryan J Ollos (previous) (diff)

comment:7 by Ryan J Ollos, 7 years ago

Possible action item for 1.0.5 and/or 1.1.4: eliminate need for duplicate editing of similar documentation, as discussion in gmessage:trac-dev:oMJ42ETozL0/slolTrwJL1YJ.

comment:8 by Ryan J Ollos, 7 years ago

To address an item in TracDev/ToDo#Codeclean-up, we could consider running a whitespace cleanup on the codebase (as in [11490]) as part of the TracDev/ReleaseChecklist.

comment:9 by Ryan J Ollos, 7 years ago

Modifications to ChangeLog page proposed in log:rjollos.git:t11914. Before committing the changes, the ChangeLog file in the source and on the wiki should probably be renamed to TracChangeLog. Most of the help pages are prefixed with Trac, and TracChangeLog is less likely to conflict with user pages.

Executing checkwiki.py shows that the ChangeLog page needs extensive updates - replacement of TracLinks with InterTracLinks.

in reply to:  9 comment:10 by Jun Omae, 7 years ago

Replying to rjollos:

Modifications to ChangeLog page proposed in log:rjollos.git:t11914. Before committing the changes, the ChangeLog file in the source and on the wiki should probably be renamed to TracChangeLog. Most of the help pages are prefixed with Trac, and TracChangeLog is less likely to conflict with user pages.

Yeah. I agree the renaming.

in reply to:  9 comment:11 by Christian Boos, 7 years ago

Replying to rjollos:

Modifications to ChangeLog page proposed in log:rjollos.git:t11914. Before committing the changes, the ChangeLog file in the source and on the wiki should probably be renamed to TracChangeLog.

Also, we could probably truncate the information about versions older than 0.12 or even 1.0, and refer to these older releases by a link to (Trac)ChangeLog@....

comment:12 by Ryan J Ollos, 7 years ago

Thanks for the feedback.

Last edited 7 years ago by Ryan J Ollos (previous) (diff)

comment:13 by Ryan J Ollos, 7 years ago

TracChangeLog added to default-pages in [13757], merged in [13758].

TracChangeLog@99 updated with release dates. 1.1/TracChangeLog added.

Last edited 7 years ago by Ryan J Ollos (previous) (diff)

comment:14 by Ryan J Ollos, 7 years ago

DONE add documentation to TracWebAdmin, add TracWebAdmin to default-pages and use TracWebAdmin throughout documentation (especially as a replacement for WebAdmin). See comment:30:ticket:11725. Delete WebAdmin and TracWebAdmin.

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

comment:15 by Ryan J Ollos, 7 years ago

comment:4 / comment:6 implemented on 1.0-stable in [13775], merged to trunk in [13776]. I've left the name as TicketQuery so that it matches the macro name. It would be nice to have the Trac prefix on all documentation pages, but we already have pages such as CamelCase and WikiPageNames for which that isn't the case. The issue is probably better handled by ideas in #2656.

comment:16 by Ryan J Ollos, 7 years ago

The PyPI shields could be useful for the TracDownload page, but I couldn't find a good place to locate any of them. Maybe someone else has a better idea

Another option would be to add a README.md for use on GitHub and add the latest release shield.

comment:17 by Ryan J Ollos, 7 years ago

Continuing the discussion from gmessage:trac-dev:oMJ42ETozL0/H33bk-qkIZAJ, I worked in rjollos.git:t11914-wiki-to-rst and executed the following:

$ ./contrib/wiki2rst.py TracInstall > INSTALL
$ ./contrib/wiki2rst.py TracUpgrade > UPGRADE

Everything looks good. There is extra whitespace in some places, but I guess that's due to html2rest and I didn't investigate further. It's probably good enough as is. The output of [[TracGuideToc]] could just be removed manually before updating the INSTALL page with each release.

Some proposed changes for the TracInstall page:

  • Installing PySQLite is probably an advanced step that could be located elsewhere: TracInstall#ForSQLite.
  • TracInstall#VersionControlSystem should contain a section for Git.
  • In TracInstall#OtherPythonPackages, for Babel we might suggest 0.9.6 or 1.3 (I think 1.0 - 1.2 have issues, and it's probably too complicated to mention that some versions of 1.0dev may work. 0.9.5 might technically work, but I doubt anyone has trouble getting 0.9.6)

I didn't look as closely at UPGRADE / TracUpgrade, but I'll do that before the release.

Last edited 7 years ago by Ryan J Ollos (previous) (diff)

in reply to:  17 comment:18 by Ryan J Ollos, 7 years ago

Replying to rjollos:

  • Installing PySQLite is probably an advanced step that could be located elsewhere: TracInstall#ForSQLite.

Done in TracInstall@398.

comment:19 by Ryan J Ollos, 7 years ago

Committed wiki2rst.py to 1.0-stable in [13814], merged to trunk in [13815]. In the future we could add documentation and dependency checking. I know the module was developed quickly and is not completely finished, but I wanted to get it in the codebase so it can be used in the release process.

comment:20 by Ryan J Ollos, 7 years ago

INSTALL and UPGRADE were updated on 1.0-stable in [13849]. It looks like maybe there are errors rendering the files in ReST, but I haven't investigated:

I imagine it is good enough though since users will usually refer to the web-based versions. We could always try to improve the html2rest later on.

comment:21 by Jun Omae, 7 years ago

The following patch would reduce errors rendering the files.

  • Remove [[TracGuideToc]] macro.
  • Remove <span class="icon">\u200b</span> in external links.
  • Strip leading and trailing white spaces from inside of <em> ... </em>. e.g. wrong rendering * Enjoy! * in INSTALL file.
  • Stop converting http://trac.edgewall.org/wiki/ to trac/wiki/default-pages/ in generated ReST text.
  • contrib/wiki2rst.py

    diff --git a/contrib/wiki2rst.py b/contrib/wiki2rst.py
    index ef18656..e8e1651 100755
    a b  
    22# -*- coding: utf-8 -*-
    33
    44import os.path
     5import re
    56import sys
    67
    78from cStringIO import StringIO
    def main():  
    4243        if not wiki.exists:
    4344            continue
    4445        context = web_context(req, wiki.resource, absurls=True)
    45         html = '<html><body>%s</body></html>' % \
    46                format_to_html(env, context, wiki.text).encode('utf-8')
     46        text = re.sub('\r?\n', '\n', wiki.text)
     47        text = re.sub(r'\[\[TracGuideToc\]\]\r?\n?', '', text)
     48        html = format_to_html(env, context, text)
     49        html = html.replace(u'<span class="icon">\u200b</span>', '')
     50        html = re.sub(r'<em>\s*([^<]*?)\s*</em>', r'<em>\1</em>', html)
     51        html = '<html><body>%s</body></html>' % html.encode('utf-8')
    4752        out = StringIO()
    4853        html2rest(html, writer=out)
    49         out = out.getvalue().replace(': http://trac.edgewall.org/wiki/',
    50                                      ': trac/wiki/default-pages/')
     54        out = out.getvalue().strip('\n')
     55        # sort links
     56        out = re.sub(r'(?:\n\.\. _[^\n]*)+\Z',
     57                     lambda m: '\n'.join(sorted(m.group(0).split('\n'))), out)
    5158        sys.stdout.write(out)
    5259
    5360

There are still some errors because one label have multiple links like this.

.. _Babel: http://babel.edgewall.org
.. _Babel: http://trac.edgewall.org/wiki/TracInstall#OtherPythonPackages

comment:22 by Jun Omae, 7 years ago

More improvements of wiki2rst.py in jomae.git@t11914.

Remained issues:

  • `mod_python`_ and `CGI`_ don't work. Link and italic markups cannot be nested in ReST.
  • One of `trac- admin`_ doesn't work due to wrapped the link.
  • `SilverCity`_ doesn't work.
  • ` [trac] htdocs_location`_ doesn't work.
  • Some Title level inconsistent:// errors.

in reply to:  8 comment:23 by Ryan J Ollos, 7 years ago

Replying to rjollos:

To address an item in TracDev/ToDo#Codeclean-up, we could consider running a whitespace cleanup on the codebase (as in [11490]) as part of the TracDev/ReleaseChecklist.

DONE Added in TracDev/ReleaseChecklist@81.

in reply to:  14 comment:24 by Ryan J Ollos, 7 years ago

Replying to rjollos:

add documentation to TracWebAdmin, add TracWebAdmin to default-pages and use TracWebAdmin throughout documentation (especially as a replacement for WebAdmin). See comment:30:ticket:11725.

Deferred to next release (comment:1:ticket:11987).

Last edited 4 years ago by Ryan J Ollos (previous) (diff)

comment:25 by Jun Omae, 7 years ago

You've pushed commits [13886:13892] in trunk during release procedure. I don't think those changes are critical. Those changes might lead something wrong. At least, the [13889] changes lead changes of message catalogs. (sorry, misunderstood) We still have milestone:1.1.5. I think it might be good to push in 1.1.5. I think we should release new versions of Trac before pushing the changes.

Last edited 7 years ago by Jun Omae (previous) (diff)

comment:26 by Ryan J Ollos, 7 years ago

I won't push any more changes. The work in comment:22 is the final step before starting testing and the release process. Feel free to push those changes, otherwise I'll push them in about 20 hours from now.

comment:27 by Ryan J Ollos, 7 years ago

TracIni@204 highlights a t.e.o specific piece of documentation that should be removed when pulling changes from the repository to the default-pages directory. In the future we could possibly make the checkwiki script strip it out.

comment:28 by Ryan J Ollos, 7 years ago

comment:22 changes committed to 1.0-stable in [13894], merged to trunk in [13895].

comment:29 by Ryan J Ollos, 7 years ago

Resolution: fixed
Status: newclosed

in reply to:  27 comment:30 by Ryan J Ollos, 4 years ago

Replying to Ryan J Ollos:

TracIni@204 highlights a t.e.o specific piece of documentation that should be removed when pulling changes from the repository to the default-pages directory. In the future we could possibly make the checkwiki script strip it out.

This was done in [15992:15994] (comment:15:ticket:12578).

in reply to:  22 comment:31 by Ryan J Ollos, 4 years ago

Replying to Jun Omae:

More improvements of wiki2rst.py in jomae.git@t11914.

Remained issues:

Will be addressed in #12835.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.