Edgewall Software
Modify

Opened 13 years ago

Last modified 9 months ago

#1395 new enhancement

Text box for duplicate when a bug is a duplicate

Reported by: ludde Owned by:
Priority: low Milestone: next-major-releases
Component: ticket system Version: devel
Severity: normal Keywords: workflow tracobject xref duplicate
Cc: daved@…, mahmoud.kassem@…, david.hopwood@…, david.goliath@…, trac@…
Release Notes:
API Changes:

Description (last modified by Christopher Lenz)

There should be a form item for writing the bug number when you mark a ticket as a duplicate. Developers are lazy, they tend to forget stuff, etc. The original bug should get a notice that given bug was marked a dupe of it

Attachments (0)

Change History (24)

comment:1 Changed 13 years ago by Christopher Lenz

Description: modified (diff)
Priority: highnormal
Severity: majorenhancement

Related to ticket relations (see #1242 and #31).

comment:2 Changed 13 years ago by Christian Boos

Owner: changed from Jonas Borgström to Christian Boos
Status: newassigned

Indeed, I was thinking of having a text area for this purpose, which would be enabled when the resolution is set to duplicate.

This text area would then contain the reference to the duplicated ticket(s) and would create a has-duplicate relation for each referenced ticket.

I'll put that soon in the source:branches/cboos-dev/trac-obj-branch and drop a note here when it's implemented.

comment:3 Changed 12 years ago by Christian Boos

Keywords: xref added

comment:4 Changed 12 years ago by jornh

WorkFlow#ExampleManipulator implements this based on code currently living in source:sandbox/workflow

comment:5 Changed 12 years ago by anonymous

Cc: daved@… added

comment:6 Changed 11 years ago by Christian Boos

Keywords: workflow tracobject added
Milestone: 1.0
Owner: Christian Boos deleted
Status: assignednew

I implemented that in the xref branch a while ago, but this needs to be reworked on other bases, now, so "un"-accepting the ticket for now.

comment:7 Changed 11 years ago by mahmoud.kassem@…

Cc: mahmoud.kassem@… added

comment:8 Changed 11 years ago by Eli Carter

This could be done with a plugin that uses the WorkFlow stuff. (And would likely be a good candidate for sample-plugins/workflow.)

comment:9 Changed 10 years ago by David Hopwood

#5197 has been marked (in two places, manually ;-) as a duplicate of this bug.

http://tn123.ath.cx/TracDuplicates/ is a plugin that solves part of the problem, although this should really be built-in.

comment:10 Changed 10 years ago by David Hopwood

Keywords: duplicate added

comment:11 Changed 10 years ago by anonymous

Cc: david.hopwood@… added

comment:12 Changed 10 years ago by david.goliath@…

Cc: david.goliath@… added

#6924 has been marked as a duplicate of this bug.

Because it wasn't identical, it is quoted below:

Duplicate tickets often contain valuable information.

It seems to me that when a ticket is marked as a duplicate, a link to the duplicate should be placed on the page for the primary ticket (the one it duplicates.)

Alternatively, when a ticket is marked as a duplicate, all of its information could be copied to (or, better yet, transcluded onto) the page of the primary ticket. Though this second solution seems much more complicated to implement, but might offer even better functionality than just linking.

comment:13 Changed 10 years ago by trac@…

Cc: trac@… added

We are beginning to use trac as a replacement for Bugzilla as we like the fact trac integrates so nicely with svn and like the wiki features too.

This is the one feature I miss from bugzilla. Will try the plugin though.

comment:14 Changed 10 years ago by Eli Carter

I just added an xref operation to wiki:AdvancedTicketWorkflowPlugin that can be used to implement the original reporter's request.

comment:15 Changed 9 years ago by Christian Boos

Milestone: 1.0experimental

#7421 closed as duplicate.

Moving this to experimental, as it's not 1.0 anymore (could well be wontfix because a plugin solution exist, or revived to be included in Trac's base ticket system in a later release).

comment:16 Changed 9 years ago by Christian Boos

#8065 closed as duplicate.

comment:17 Changed 8 years ago by Christian Boos

Milestone: experimentalnext-major-0.1X

Milestone experimental deleted

comment:18 Changed 8 years ago by Christian Boos

Milestone: next-major-0.1X
Resolution: wontfix
Status: newclosed

See comment:15.

comment:19 Changed 8 years ago by david-sarah@…

Please reconsider the closing of this ticket.

This bug had four duplicates (#5197, #6924, #7421, #8065), suggesting that it should be considered basic functionality and supported by default. I consider this a glaring omission in Trac compared to most comparable bug tracking systems.

The two plugins mentioned do not adequately implement the requested functionality:

  • The TracDuplicates plugin does not indicate the duplicate bug(s) (in either direction) in the bug header.
  • The TracHacks:wiki:AdvancedTicketWorkflowPlugin is complicated by many options irrelevant to duplicates, and the documentation of the xref option comes with the disclaimer "Note that the implementation of this operation is not robust."

comment:20 in reply to:  19 Changed 8 years ago by Christian Boos

Milestone: next-major-0.1X
Priority: normallow

Replying to david-sarah@…:

Please reconsider the closing of this ticket.

Thanks for your well documented analysis.

This bug had four duplicates (#5197, #6924, #7421, #8065), suggesting that it should be considered basic functionality and supported by default. I consider this a glaring omission in Trac compared to most comparable bug tracking systems.

This is indeed a good indicator, but sometimes even in this case the feature could be provided as a plugin, or as an optional component that we could bundle in tracopt.

The two plugins mentioned do not adequately implement the requested functionality:

  • The TracDuplicates plugin does not indicate the duplicate bug(s) (in either direction) in the bug header.
  • The TracHacks:wiki:AdvancedTicketWorkflowPlugin is complicated by many options irrelevant to duplicates, and the documentation of the xref option comes with the disclaimer "Note that the implementation of this operation is not robust."

I hesitated for the wontfix, which in the end was merely based on the supposition that the existing plugins were providing the requested feature in a satisfying way.

If this is not the case, one possible reason could be that the feature is much more "naturally" done in Trac itself (easier to implement in a more robust way). As I remember having coded that feature once as part of an experimental branch (comment:2, comment:6), this could well interest me again in the future, e.g. after or jointly with #31, eventually based on something like TracDev/Proposals/TracRelations.

comment:21 Changed 8 years ago by Christian Boos

Resolution: wontfix
Status: closedreopened

comment:23 Changed 2 years ago by Ryan J Ollos

Status: reopenednew

comment:24 Changed 9 months ago by Ryan J Ollos

#12703 closed as a duplicate.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned.
as The resolution will be set.
The owner will be changed from (none) to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.