Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#5197 closed enhancement (duplicate)

automatically link duplicates

Reported by: kontakt at meitzner dot net Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version:
Severity: normal Keywords: link backlink duplicates dupes dedupe
Cc: david.hopwood@… Branch:
Release Notes:
API Changes:

Description

When marking a ticket as duplicate of another, I'd find it neat if the referenced Ticked would automatically receive an update in terms of a backlink to the duplicate.

Sometimes multiple tickets describe an issue in differnt ways, have collected annotations, etc. I've noticed the request for merging tickets here, but for me it would be sufficient, if the chosen "original" could somehow backlink to duplicates automatically.

A comment like "#1234 has been marked duplicate of this ticket" or an option to list all duplicates would do, I think.

This way, a developer taking on an issue could easily browse through all the "written-down thoughts" on the issue, and there is no need to copy-and-paste comments or even touch two tickets just because one of them is a duplicate of the other.

Hope you get my point… it's late :-)

Attachments (0)

Change History (6)

comment:1 by anonymous, 12 years ago

Keywords: backlink added; backling removed

comment:2 by Emmanuel Blot, 12 years ago

This seems to be a specialized request for #31.

in reply to:  2 comment:3 by anonymous, 12 years ago

I did a small plugin that will allow to dupe against another bug.

See: http://tn123.ath.cx/TracDuplicates/

comment:4 by ThurnerRupert, 12 years ago

Resolution: duplicate
Status: newclosed

seems to be fixed by the plugin mentioned above. for the general solution should we mark this as duplicate of #31?

comment:5 by David Hopwood, 12 years ago

Cc: david.hopwood@… added
Resolution: duplicate
Severity: minornormal
Status: closedreopened

It seems as though this can be fixed independently of #31, and therefore is not a duplicate, even if there is some overlap.

#31 is about blocking dependencies as supported by BugZilla and other trackers; it also involves being able to see dependency graphs in the UI, which is more complex than support for duplicates.

Since the comment that mentions the duplicate may be buried in the middle of a long page, duplicates should also be mentioned in the ticket header. (The TracDuplicates plugin does not do this, I think.) I was very surprised when evaluating Trac against other bug tracking systems, that support for tracking duplicates is not built-in.

comment:6 by David Hopwood, 12 years ago

Resolution: duplicate
Status: reopenedclosed

This is, however, a duplicate of #1395.

BTW, good support for duplicates is basic functionality needed by all projects; a plugin shouldn't be required, or it should be installed by default.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.