Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#5198 closed defect (duplicate)

Attempt to open the timeline through web interface failed

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

The error was fortunately transient, but it is somewhat disconcerting. Here is the error stack.

Python Traceback

Traceback (most recent call last):
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/web/main.py", line 191, in dispatch
    chosen_handler = self._pre_process_request(req, chosen_handler)
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/web/main.py", line 263, in _pre_process_request
    chosen_handler = f.pre_process_request(req, chosen_handler)
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/versioncontrol/api.py", line 73, in pre_process_request
    self.get_repository(req.authname) # triggers a sync if applicable
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/versioncontrol/api.py", line 101, in get_repository
    repos = self._connector.get_repository(rtype, rdir, authname)
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 260, in get_repository
    crepos = CachedRepository(self.env.get_db_cnx(), repos, None, self.log)
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 34, in __init__
    self.sync()
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 88, in sync
    "VALUES (%s,%s,%s,%s)", (str(current_rev),
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/db/sqlite_backend.py", line 56, in execute
    args or [])
  File "/opt/trac-0.10.3.1/lib/python2.4/site-packages/trac/db/sqlite_backend.py", line 48, in _rollback_on_error
    return function(self, *args, **kwargs)
IntegrityError: column rev is not unique

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 13 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #3831, itself closed as duplicate of #4043 (though not exactly the same).

All those repository cache issues should now be fixed in 0.10.4 (and 0.11 trunk as well, of course).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.