Edgewall Software
Modify

Opened 16 years ago

Closed 15 years ago

Last modified 14 years ago

#3831 closed defect (duplicate)

Timeline gives an error after adjusting milestones

Reported by: zamoose@… Owned by: Christian Boos
Priority: normal Milestone:
Component: version control Version: 0.9.6
Severity: minor Keywords: resync
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I cannot view the timeline now, after having created, renamed and deleted some milestones. I receive the following error now when I try to hit the page:

 Trac detected an internal error:

column rev is not unique

The full trace is shown below:

'''Python traceback'''

Traceback (most recent call last):
  File "/home/zamoose/packages/lib/python2.3/site-packages/trac/web/cgi_frontend.py", line 130, in run
    dispatch_request(req.path_info, req, env)
  File "/home/zamoose/packages/lib/python2.3/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/home/zamoose/packages/lib/python2.3/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/home/zamoose/packages/lib/python2.3/site-packages/trac/Timeline.py", line 140, in process_request
    filters)
  File "/home/zamoose/packages/lib/python2.3/site-packages/trac/versioncontrol/web_ui/changeset.py", line 116, in get_timeline_events
    chgset = repos.get_changeset(rev)
  File "/home/zamoose/packages/lib/python2.3/site-packages/trac/versioncontrol/cache.py", line 42, in get_changeset
    self.sync()
  File "/home/zamoose/packages/lib/python2.3/site-packages/trac/versioncontrol/cache.py", line 84, in sync
    "VALUES (%s,%s,%s,%s)", (str(current_rev),
  File "/home/zamoose/packages/lib/python2.3/site-packages/trac/db.py", line 219, in execute
    args or [])
  File "/home/zamoose/packages/lib/python2.3/site-packages/trac/db.py", line 211, in _rollback_on_error
    return function(self, *args, **kwargs)
IntegrityError: column rev is not unique

You may view it yourself at http://trac.zamoose.org/timeline

Attachments (0)

Change History (7)

comment:1 by zamoose, 16 years ago

Interesting. It no longer gives the error after editing several Wiki pages. Hmmm. Any idea what went wrong so that I can avoid it in the future?

comment:2 by Christian Boos, 16 years ago

Component: timelineversion control
Keywords: resync added
Milestone: 0.10.2
Owner: changed from Jonas Borgström to Christian Boos
Priority: highnormal
Severity: normalminor

This had nothing to do with milestones, that was simply a resync attempt triggered by the timeline, which failed because a concurrent resync was already in progress.

The resync should silently complete in this case.

comment:3 by sid, 16 years ago

Looks pretty similar to #4043

in reply to:  3 comment:4 by Christian Boos, 15 years ago

Milestone: 0.10.4
Resolution: duplicate
Status: newclosed

Replying to sid:

Looks pretty similar to #4043

Not a duplicate of that one, because: "It no longer gives the error after editing several Wiki pages". So it's rather the expected occasional behavior on clashing concurrent resync attempts, as discussed in #4586.

#4043 is certainly related, but on PostgreSQL, there's apparently sometimes a very critical condition as the db remains in an inconsistent state, for some reason, so that every further connection attempt will fail.

comment:5 by jp [spam] jhcore.com, 15 years ago

I was getting the same error, except I could not navigate anywhere away from it. I had been doing some major subversion directory moving before hand. I fixed it by resync'ing:

trac-admin {site} resync

in reply to:  5 comment:6 by Christian Boos, 15 years ago

Replying to jp [spam jhcore.com]:

I was getting the same error, except I could not navigate anywhere away from it. I had been doing some major subversion directory moving before hand. I fixed it by resync'ing:

trac-admin {site} resync

Yes, this is actually the #4043 problem, which was actually not postgresql specific.

There's a fix in preparation and we'll soon release 0.10.4 with that fix.

comment:7 by sid, 14 years ago

#6227 was marked as duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.