Edgewall Software
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12703 closed enhancement (duplicate)

ticket can be closed as a duplicate of itself

Reported by: bastiK Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

A ticket can be closed as a duplicate referencing itself as the duplicated ticket. (E.g. https://josm.openstreetmap.de/ticket/14397)

This makes no sense and could be rejected with an error message.

Trac 1.2

Attachments (0)

Change History (3)

comment:1 by Ryan J Ollos, 3 years ago

Resolution: invalid
Status: newclosed

comment:2:ticket:14397 is just text. It's no different than writing I'm leaving this ticket open, while I close it.

Trac doesn't store the duplicate field in a table, for that you should look at something like th:TracDupPlugin or TracDuplicates. If those plugins aren't good, something could be written to provide a text box for entering the duplicate ticket reference (e.g. Apache Bloodhound's TicketRelations feature provides this).

Last edited 3 years ago by Ryan J Ollos (previous) (diff)

comment:2 by Ryan J Ollos, 3 years ago

Resolution: invalidduplicate

Another interpretation of the request is that it's a duplicate of #1395.

comment:3 by bastiK, 3 years ago

We are using the AdvancedTicketWorkflowPlugin for this. (I was not aware when submitting the bug.)

Last edited 3 years ago by Ryan J Ollos (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.