Edgewall Software
Modify

Opened 15 years ago

Closed 13 years ago

Last modified 11 years ago

#629 closed enhancement (fixed)

svn blame support

Reported by: anonymous Owned by: Christian Boos
Priority: normal Milestone: 0.11
Component: version control/browser Version: 0.7.1
Severity: major Keywords: annotation blame
Cc: zilvinas@…, pjenvey@…, maze@…, trac@…, domonom@…, gary.wilson@…, tapted@…, mithrandir@…, alec.munro@… Branch:
Release Notes:
API Changes:

Description

Having svn blame (aka annotate) in the source browser would be real nice.

Thanks for nice job so far, guys.

Attachments (0)

Change History (30)

comment:1 by daniel, 15 years ago

Milestone: 2.0

comment:2 by Christopher Lenz, 15 years ago

#1215 has been marked as duplicate of this ticket.

comment:3 by anonymous, 15 years ago

Cc: zilvinas@… added

comment:4 by Christopher Lenz, 14 years ago

Owner: changed from Jonas Borgström to Christopher Lenz
Status: newassigned

comment:5 by Christopher Lenz, 14 years ago

Milestone: 2.01.0

Experimental implementation of blame support is in source:branches/cmlenz-dev/blame.

comment:6 by Russ Brown, 14 years ago

For extra brownie points on this, see if there is an svk:merge property somewhere and attempt to resolve merges to find the true authors of the lines merged.

That would be *very* smart.

comment:7 by anonymous, 14 years ago

#2160 has been marked as duplicate of this ticket.

comment:8 by anonymous, 14 years ago

Any news on when this is going to be integrated. It would be wonderful to have for the next milestone.

comment:9 by joe@…, 14 years ago

Sorry update! The last comment was mine, but I forgot to add my email address.

comment:10 by Christian Boos, 14 years ago

Milestone: 1.00.11

It's currently scheduled for milestone:0.11

cmlenz: can you move your branch to the sandbox, as blame support is also something I'd like to contribute to.

comment:11 by sven.reimers@…, 14 years ago

I started hacking away at a plugin proving a IHTMLPreviewAnnotator to show blame information along the lines cmlenz provided in his branch. But still there is a problem to access the req object during annotating, just line number and content is passed, additionally the only lineno is requested from inside trac. Anybody any idea if at least the api will be adopted (should not be that complex, since there seems to be only one annotator) - then it should impose no further problem developing this as a plugin (maybe some *.css, etc.). So anybody?

comment:12 by sven.reimers@…, 14 years ago

Forgot one other problem. The user should be able to select which annotaters are used, so some gui changes would be necessary here as well, but I think cmlenz has already provided some interesting things in his branch as well. Should this be tracked in a different ticket? Maybe this can be fixed in 0.10 time frame (allowing for plugin)

comment:13 by anonymous, 14 years ago

Cc: pjenvey@… added

comment:14 by anonymous, 14 years ago

Cc: maze@… added

comment:15 by Christian Boos, 14 years ago

Another duplicate request for this: #3023

comment:16 by anonymous, 14 years ago

Cc: trac@… added

comment:17 by anonymous, 14 years ago

Any news on this? Quite strange for Trac not to have the blame (I prefer the term "praise") feature since cvsweb et al have it.

comment:18 by dombot@…, 14 years ago

Cc: dombot@… added

This would be a very handy feature and would be a good potential advantage to convince the dev team from moving from CVS + Bugzilla + Bonsai to Subversion + Trac.

comment:19 by anonymous, 14 years ago

Cc: domonom@… added; dombot@… removed

comment:20 by anonymous, 14 years ago

Cc: gary.wilson@… added

comment:21 by Trent Apted <tapted@…>, 13 years ago

Cc: tapted@… added

I am marking a groupwork software project/assignment currently (and have been for about 12 hours straight now). Students must use Trac/SVN and we generate some interesting visualizations from Trac and SVN logs/history

there are technical reports if people are interested: Wattle Tree: What’ll it Tell Us? and [longer] The Big Five and Visualisations of Team Work Activity (the "Big Five" are components of teamwork, according to Salas et al. in the Journal of Small Group Research 36(5), 2005).

However, sometimes you really want the details from an SVN blame.. so.. my fingers are crossed, in the hope 0.11 makes it out before August in time for the next semester :)

comment:22 by anonymous, 13 years ago

Cc: mithrandir@… added

in reply to:  description comment:23 by alec.munro@…, 13 years ago

Cc: alec.munro@… added

What needs to be done to get this working? I would really like to see more progress on 0.11, and I think I could probably help out with this particulur issue.

comment:24 by Christian Boos, 13 years ago

#3023 has been marked as duplicate… again. In particular, check this requirement.

comment:25 by garyo@…, 13 years ago

Not a requirement, but a "would be nice" feature for blame: in Emacs, the blame ("annotate") mode colors source lines by their age. Old lines are blue, new are bright red, and so on. This way the recent changes stand out nicely. I would suggest doing this only for the rev numbers or dates columns in the blame output in trac, since the source lines already have their own syntax colorization. I think a default color scheme of 6 months ago gets blue, today gets red, and linearly in between, would be fine. Not sure arbitrary colors like this are easy with CSS/html though?

comment:26 by Christian Boos, 13 years ago

Severity: normalmajor

comment:27 by Christian Boos, 13 years ago

Keywords: annotation added; svn removed
Owner: changed from Christopher Lenz to Christian Boos
Status: assignednew

in reply to:  25 comment:28 by Christian Boos, 13 years ago

Replying to garyo@genarts.com:

Not a requirement, but a "would be nice" feature for blame: in Emacs, the blame ("annotate") mode colors source lines by their age. Old lines are blue, new are bright red, and so on. This way the recent changes stand out nicely. I would suggest doing this only for the rev numbers or dates columns in the blame output in trac, since the source lines already have their own syntax colorization.

Done so in r4484, looks great, thanks for the suggestion!

comment:29 by Christian Boos, 13 years ago

Resolution: fixed
Status: newclosed

Blame branch merged in r4561.

Issues with the blame feature should be opened as new defect tickets. Feedback and improvements on the feature are welcomed of course, but the base feature is there and seems to be solid.

Note that the TracMercurial plugin (the 0.11 variant, i.e. source:sandbox/mercurial-plugin-0.11) also supports the new blame feature.

comment:30 by elmarco, 11 years ago

\o/ thanks

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.