Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#575 closed defect (duplicate)

Navigation bar layout broken in Opera

Reported by: anonymous Owned by: Jonas Borgström
Priority: low Milestone:
Component: general Version: 0.7.1
Severity: minor Keywords: layout
Cc: Branch:
Release Notes:
API Changes:

Description

In Opera 7 web browser, the button bar ("Wiki", "Timeline", "Browse Source", "View Tickets", "New Ticket", "Search") is arranged vertically instead of horizontally.

Normally this doesn't cause any real problems, but on a few pages it obscures some of the buttons.

This bug doesn't occur in IE6 or Firefox.

Please make sure that you are generating correct W3C compliant CSS/XHTML layout code and if you can't find anything fishy, contact Opera.

Attachments (1)

opera.png (12.0 KB ) - added by anonymous 15 years ago.
Opera's rendering of option bar

Download all attachments as: .zip

Change History (13)

comment:1 by anonymous, 15 years ago

Resolution: fixed
Status: newclosed

comment:2 by anonymous, 15 years ago

Resolution: fixed
Status: closedreopened

comment:3 by dobes, 15 years ago

New development: now that there are Ads By Google on the trac site for trac itself, I can't click on the 'search' button - it is obscured by the 'ads by google' box. This probably only happens in Opera 7.

comment:4 by dobes, 15 years ago

New development: now that there are Ads By Google on the trac site for trac itself, I can't click on the 'search' button - it is obscured by the 'ads by google' box. This probably only happens in Opera 7.

comment:5 by Kai Backman <trac-contact@…>, 15 years ago

Summary: Vertical button rendering in Opera 7Rendering of Google Adwords

Changed scope of the ticket to reflect that Google advertisements also hide the rightmost

columns in most ticket reports for the first 20 rows. The setup is standard IE 6 with a screen resolution of 1024x768.

comment:6 by mario at ruggier.org, 15 years ago

On OS X Panther, running Safari 1.2.3, the Google ads also hide the rightmost columns in ticket reports, unless the browser window is made wide enough, and the screen is big enough… the table output of the reports seem to take a fixed width space, while the ads are floating flush right. However, on the search page results, the results take up a variable width, thus fitting nicely to the left of the ads. Maybe a similar behaviour shuld be adopted for ticket reports.

comment:7 by tdooher.lists AT naturalmotion.com, 15 years ago

I've found a fix/workaround that prevents Opera breaking the navbar. Instead of floating left and filling in from the right, float right and fill in from the left. Patches below for trac.css and one to apply either to the default header.cs or the site override copy to reverse the rendering order:

  • trac.css
--- trac.css.original   2004-07-15 13:10:30.000000000 +0100
+++ trac.css    2004-09-07 11:20:26.000000000 +0100
@@ -108 +108 @@
-#navbar li { float: left }
+#navbar li { float: right }
  • header.cs
--- header.cs.original  2004-09-07 11:52:27.000000000 +0100
+++ header.cs   2004-09-07 11:51:57.000000000 +0100
@@ -95,12 +94,0 @@
-  <?cs call:navlink("Wiki", $trac.href.wiki, $wiki_view,
-                    $trac.acl.WIKI_VIEW, "1") ?>
-  <?cs call:navlink("Timeline", $trac.href.timeline, "timeline",
-                    $trac.acl.TIMELINE_VIEW, "2") ?>
-  <?cs call:navlink("Browse Source", $trac.href.browser, $browser_view,
-                    $trac.acl.BROWSER_VIEW, "") ?>
-  <li style="display: none"><a href="<?cs var:$trac.href.newticket ?>"
-                    accesskey="7">New Ticket (Accessibility)</a></li>
-  <?cs call:navlink("View Tickets", $trac.href.report, $ticket_view,
-                    $trac.acl.REPORT_VIEW, "") ?>
-  <?cs call:navlink("New Ticket", $trac.href.newticket, "newticket",
-                    $trac.acl.TICKET_CREATE, "9") ?>
@@ -108,0 +97,12 @@
+  <?cs call:navlink("New Ticket", $trac.href.newticket, "newticket",
+                    $trac.acl.TICKET_CREATE, "9") ?>
+  <?cs call:navlink("View Tickets", $trac.href.report, $ticket_view,
+                    $trac.acl.REPORT_VIEW, "") ?>
+  <li style="display: none"><a href="<?cs var:$trac.href.newticket ?>"
+                    accesskey="7">New Ticket (Accessibility)</a></li>
+  <?cs call:navlink("Browse Source", $trac.href.browser, $browser_view,
+                    $trac.acl.BROWSER_VIEW, "") ?>
+  <?cs call:navlink("Timeline", $trac.href.timeline, "timeline",
+                    $trac.acl.TIMELINE_VIEW, "2") ?>
+  <?cs call:navlink("Wiki", $trac.href.wiki, $wiki_view,
+                    $trac.acl.WIKI_VIEW, "1") ?>

This looks identical in Firefox 0.93, Opera 7.54 and IE 6.1, aolving the original bug, but not the adwords stuff.

comment:8 by tdooher.lists AT naturalmotion.com, 15 years ago

It still doesn't work in Opera 7.23, it seems. The rendering is still stacked on the right, but is also right-justified which, if anything, makes it worse.

by anonymous, 15 years ago

Attachment: opera.png added

Opera's rendering of option bar

comment:9 by Christopher Lenz, 15 years ago

Resolution: wontfix
Status: reopenedclosed
Summary: Rendering of Google AdwordsNavigation bar layout broken in Opera

See #372 and [510]. This is a rendering bug in Opera that we are unable to work around. As explained in #372, reversing the order of the "buttons" in the markup is not an option.

Luckily, the bug seems to be fixed in Opera 7.6 (as of preview 1 on windows), so I'm going to close this bug.

comment:10 by anonymous, 15 years ago

to fix it, just remove the following lines from trac.css

 /* Hide from IE/Mac \*/
 display: block;
 float: left;
 /* Unhide */

comment:11 by Christopher Lenz, 15 years ago

Keywords: layout added
Resolution: wontfix
Status: closedreopened

That's not a fix and breaks other aspects of the layout.

comment:12 by Christopher Lenz, 15 years ago

Resolution: duplicate
Status: reopenedclosed

This is a duplicate of #371.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.