Edgewall Software
Modify

Opened 16 years ago

Closed 12 years ago

Last modified 12 years ago

#449 closed enhancement (fixed)

Link from tickets to milestones

Reported by: Christopher Lenz Owned by: Christian Boos
Priority: normal Milestone: 0.11
Component: ticket system Version:
Severity: normal Keywords:
Cc: somekool@…, m@…, garyo@… Branch:
Release Notes:
API Changes:

Description

If a ticket has a milestone yet, the milestone name should be a link the the corresponding milestone page of the roadmap, if the remote user has MILESTONE_VIEW perms.

Attachments (0)

Change History (18)

comment:1 by Christopher Lenz, 15 years ago

Milestone: 0.8

Nice to have but not essential, I guess. Later.

comment:2 by Christopher Lenz, 15 years ago

Component: roadmapticket system
Owner: changed from Christopher Lenz to Jonas Borgström

comment:3 by Christopher Lenz, 15 years ago

Resolution: duplicate
Status: newclosed

Superseded by #832 which has a broader scope.

comment:4 by Christopher Lenz, 15 years ago

Resolution: duplicate
Status: closedreopened

Actually, there's a difference between this ticket and #832. Note though that the two requests conflict with each other.

comment:5 by vittorio, 14 years ago

Severity: trivialenhancement

comment:6 by Christian Boos, 14 years ago

Owner: changed from Jonas Borgström to Christian Boos
Status: reopenednew

comment:7 by Christian Boos, 14 years ago

Milestone: 1.0
Status: newassigned

#1810 (marked as duplicate) proposes to also create links inside ticket changes, e.g.

milestone set to 1.0

comment:8 by Matthew Good, 14 years ago

#2155 has been marked as a duplicate of this ticket.

comment:9 by Christian Boos, 14 years ago

Status: assignednew

Note though that the two requests (i.e. this one and #832) conflict with each other.

What about this: as a milestone exist as a Trac object, one would expect to end up on the page corresponding to that object when clicking on its reference…

OTOH, components and versions are not (yet) Trac objects, so clicking on them could lead to some query (e.g. the other tickets having the same component or version, … but would that be helpful?).

In the end, if there must be a choice, I'd favor the approach presented here rather than the one of #832.

(unaccepting the ticket, as I've not started working on that)

comment:10 by anonymous, 14 years ago

Cc: somekool@… added

comment:11 by Christian Boos, 13 years ago

Milestone: 1.00.11

#990 and #3547 are also duplicate requests for this feature. I wonder if it's not already implemented in the WorkFlow sandbox.

comment:12 by Markus Tacker <m@…>, 13 years ago

Cc: m@… added
Version: devel

comment:13 by anonymous, 13 years ago

Cc: garyo@… added

Can't just change cc due to akismet without some other text, so I'll just let you know that I would really like to see this. It's simple, but since all the ticket fields are in a loop now, it needs a bit more than the half hour of massaging I could give it…

comment:14 by Christian Boos, 13 years ago

Priority: lownormal

#4538 was closed as duplicate.

comment:15 by direvus@…, 13 years ago

+1. This isn't just "nice to have", it's also "strange not to have". Most everything else in Trac is fabulously interlinked, and then we have this little oddity.

comment:16 by sbriney@…, 13 years ago

I also think that this would be a very useful feature. I am always trying to get from a ticket, back to its Milestone.

comment:17 by Christian Boos, 13 years ago

Status: newassigned

Done in r5479 (in the FieldRefactoring branch)

comment:18 by Christian Boos, 12 years ago

Milestone: 0.11.10.11
Resolution: fixed
Status: assignedclosed

Ported to trunk in r5813.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.