Edgewall Software
Modify

Opened 13 years ago

Last modified 4 years ago

#3255 new enhancement

Context-sensitive new ticket prefill

Reported by: s.lipnevich@… Owned by:
Priority: low Milestone: next-major-releases
Component: ticket system Version: none
Severity: normal Keywords: jquery draganddrop ticketclone
Cc: Branch:
Release Notes:
API Changes:

Description

I'd like to extend the idea behind a worksforme-ed #3253 as follows: it'd be nice to enter a ticket quickly based on the conditions I'm looking at right now.

Example: I create a query for owner X and milestone Y using TracQuery. I review the results and decide to add to the workload of X and create one more task. It'd be great to simply be able to click on a link that says Create new ticket in this view (not a good wording) or something like that.

Similarly, and that's what #3253 was proposing, it'd be nice to create a ticket right from the milestone's page that is assigned to this milestone. Or create a ticket assigned to this milestone and a particular component by clicking one of the [now imaginary] knobs next to one of the sort by component progress bars on the right of the milestone's view. Or by clicking somewhere in the query that results from clicking on this progress bar… You get the idea.

Moreover, I actually would prefer the standard New Ticket action to be context-sensitive as I describe above and always prefill ticket fields for me based on what is in the current page's view.

To extend this beyond milestones and queries, when I'm looking at a Wiki page or a commit log or a source code item, and I click New Ticket, I'd be glad to see that there's a TracLink-ified reference to that object. Maybe that's one of the ideas TracObjectModelProposal is trying to accommodate, but it would need help from Trac on how to deduce some relations between Trac objects, in this case to help fill out a ticket more quickly.

Attachments (0)

Change History (14)

comment:1 by Matthew Good, 13 years ago

The "New Ticket" link on the main navigation should not be context-sensitive. If context-sensitive ticket links are added they should go in the "ctxtnav" list below the main menu bar.

comment:2 by anonymous, 13 years ago

This is similar to #2281, possible a duplicate of it. #2281 specifically talks about referencing a source code page, where this ticket uses the example of a custom query.

comment:3 by Christian Boos, 13 years ago

Resolution: wontfix
Status: newclosed

Well, I also don't think it's very common you want to create a ticket related to what you're currently looking at (and frankly I don't get the reference to the Trac object stuff, here ;-) ).

The more convincing use case was probably the first one, when you're in a custom query view and want to create a new ticket matching the current criterions. Here, I'd suggest that the "ticket cloning" facility of #4686 could be used instead.

So overall, I'd like to issue a wontfix for this one as well.

in reply to:  3 comment:4 by anonymous, 13 years ago

Resolution: wontfix
Status: closedreopened

Replying to cboos:

Well, I also don't think it's very common you want to create a ticket related to what you're currently looking at (and frankly I don't get the reference to the Trac object stuff, here ;-) ).

Well, without a voting system you can't really say if this request is popular or not. I only would like to note that all Trac users are different and dismissing a request based on one opinion is a bit harsh. I did mark it as lowest priority enhancement after all. Feel free to close it now :-).

comment:5 by Christian Boos, 13 years ago

Component: generalticket system
Keywords: jquery draganddrop added
Milestone: 1.0
Owner: changed from Jonas Borgström to Christian Boos
Priority: lowestlow
Severity: trivialnormal
Status: reopenednew

Ok, so you got me to think again about this issue.

To be honest, there are already several "votes" for this feature: sergey and iheitlager from ticket #2281, which I closed as duplicate.

What hold me back on the idea was that I thought that adding lots of "new ticket" links would probably clutter the interface too much, in particular w.r.t. the frequency of use for this feature. A notable exception for this being the "Clone Ticket" button on the ticket page itself (#4686).

As mgood said in comment:1, the "New Ticket" main navigation item itself is context insensitive by design, so we can't use this either.

So I wonder if it wouldn't be a good idea to "carry over" the context information to the "New Ticket" action. In other words, with some javascript help, drag a link and drop it over the "New Ticket" tab. That would create a new ticket with the dropped link given as a "context" argument. The ticket module would know how to decipher the context link, in particular for query links, it would know how to use the link parameters to prefill the corresponding fields.

in reply to:  5 comment:6 by s.lipnevich@…, 13 years ago

Replying to cboos:

To be honest, there are already several "votes" for this feature: sergey…

The previous comment was mine as well :-).

As mgood said in comment:1, the "New Ticket" main navigation item itself is context insensitive by design, so we can't use this either.

Not a problem really, I probably went too far in trying to describe the enhancement.

So I wonder if it wouldn't be a good idea to "carry over" the context information to the "New Ticket" action. In other words, with some javascript help, drag a link and drop it over the "New Ticket" tab. That would create a new ticket with the dropped link given as a "context" argument. The ticket module would know how to decipher the context link, in particular for query links, it would know how to use the link parameters to prefill the corresponding fields.

I'm a bit confused by this description, sorry! Specifically, what is a "New Ticket" tab? For example, if I want to create a ticket related to a Wiki page and I have this page in front of me, what are the steps I would have to follow?

comment:7 by Christian Boos, 13 years ago

First, you'd need to have an easily selectable link to that page. This is not yet there, it could done in a variety of ways, like making the main title a link to the page itself.

Another possibility would be to have a title path navigation in the upper left corner, similar to what we have for repository files (but smaller). E.g. if you're on the TracDev/Proposals/DataModel page, you'd have: TracDev / Proposals / DataModel

Then you would drag that link and drop it over the New Ticket area in the navigation bar (the place where you'd normally click to create a new ticket). This drop would also create a new ticket, but in this case the description would start with something like: Related to …(the title of the page).

If the link is a link to a query, the query paramaters would be reused to set the ticket fields. This would have the advantage of making it possible to reuse any of the ticket query links present on a milestone page, as you proposed, but without having to create one additional button or action link for each of this query…

in reply to:  7 comment:8 by s.lipnevich@…, 13 years ago

Replying to cboos:

Then you would drag that link and drop it over the New Ticket area in the navigation bar (the place where you'd normally click to create a new ticket). This drop would also create a new ticket, but in this case the description would start with something like: Related to …(the title of the page).

If the link is a link to a query, the query paramaters would be reused to set the ticket fields. This would have the advantage of making it possible to reuse any of the ticket query links present on a milestone page, as you proposed, but without having to create one additional button or action link for each of this query…

Such a nifty idea! And a smart reuse of existing screen controls too. Finally, navigation path for Wiki pages would help those with hierarchical page names, which are very popular. Triple play :-).

comment:9 by anonymous, 11 years ago

Resolution: fixed
Status: newclosed

comment:10 by Remy Blank, 11 years ago

Resolution: fixed
Status: closedreopened

Please don't close tickets as anonymous.

comment:11 by Christian Boos, 9 years ago

Milestone: 1.0unscheduled

Milestone 1.0 deleted

comment:12 by Remy Blank, 9 years ago

Milestone: triagingnext-major-0.1X

I'm not sure about the "drag & drop" functionality, as it's difficult to discover without reading the documentation. But lots of good ideas here anyway :)

comment:13 by Christian Boos, 7 years ago

Keywords: ticketclone added

comment:14 by Ryan J Ollos, 4 years ago

Owner: Christian Boos removed
Status: reopenednew

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned. Next status will be 'new'.
as The resolution will be set. Next status will be 'closed'.
The owner will be changed from (none) to anonymous. Next status will be 'assigned'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.