Edgewall Software
Modify

Opened 14 years ago

Closed 12 years ago

#2281 closed enhancement (duplicate)

Pre-filling ticket information based on current page

Reported by: sergey Owned by: Jonas Borgström
Priority: lowest Milestone:
Component: ticket system Version: none
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I was filing a defect about a source code file and it occurred to me that when I clicked New Ticket, I was on this file's view in the Source Browser. It would be convenient if Trac used some predefined template to fill in ticket details with reference to this source file. As a first step, a simple source:... link would suffice.

I'm sure this idea can be expanded to other types of pages, e.g. clicking New Ticket on a Wiki page would pre-fill a new ticket with this page's wiki:... link.

Attachments (0)

Change History (4)

comment:1 by iheitlager, 14 years ago

As also requested in ticket #2581 this would support the code review process significantly. Not always you want to review on code directly. So a facility to add tickets to sources would help tremendously.

comment:2 by iheitlager, 14 years ago

No short memory, #2513 that is.

comment:3 by sid, 13 years ago

Similar to #3255. Possible a dupe of it.

comment:4 by Christian Boos, 12 years ago

Resolution: duplicate
Status: newclosed

Right, see #3255.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.