Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3256 closed enhancement (duplicate)

Context-sensitive new ticket prefill

Reported by: s.lipnevich@… Owned by: Jonas Borgström
Priority: lowest Milestone:
Component: general Version: none
Severity: trivial Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I'd like to extend the idea behind a worksforme-ed #3253 as follows: it'd be nice to enter a ticket quickly based on the conditions I'm looking at right now.

Example: I create a query for owner X and milestone Y using TracQuery. I review the results and decide to add to the workload of X and create one more task. It'd be great to simply be able to click on a link that says Create new ticket in this view (not a good wording) or something like that.

Similarly, and that's what #3253 was proposing, it'd be nice to create a ticket right from the milestone's page that is assigned to this milestone. Or create a ticket assigned to this milestone and a particular component by clicking one of the [now imaginary] knobs next to one of the sort by component progress bars on the right of the milestone's view. Or by clicking somewhere in the query that results from clicking on this progress bar… You get the idea.

Moreover, I actually would prefer the standard New Ticket action to be context-sensitive as I describe above and always prefill ticket fields for me based on what is in the current page's view.

To extend this beyond milestones and queries, when I'm looking at a Wiki page or a commit log or a source code item, and I click New Ticket, I'd be glad to see that there's a TracLink-ified reference to that object. Maybe that's one of the ideas TracObjectModelProposal is trying to accommodate, but it would need help from Trac on how to deduce some relations between Trac objects, in this case to help fill out a ticket more quickly.

Attachments (0)

Change History (2)

comment:1 by anonymous, 13 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #3255, Trac produced an error so I reposted…

comment:2 by Christian Boos, 13 years ago

Do you remember what was that error?

Apparently, the creation of the ticket succeeded, but the notification failed, so it must have been a problem in between.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.