Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2945 closed enhancement (fixed)

tickets with version control

Reported by: anonymous Owned by: Christian Boos
Priority: normal Milestone: 0.11
Component: ticket system Version: 0.9.4
Severity: major Keywords: tracobject version history
Cc: rhind@… Branch:
Release Notes:
API Changes:

Description

it would be great to have the tickets under version control. with this you can use the ticket system easy as an requirement tool.

Attachments (0)

Change History (21)

comment:1 by coderanger, 13 years ago

Ticket changes are indeed versioned already, though there is no real support for things like rollbacks (yet). What would you need in addition to the current features?

comment:2 by Christian Boos, 13 years ago

Component: generalticket system
Keywords: ticket added; tickes removed
Summary: tikets with version controltickets with version control

Are you thinking about having an history for the description, similar to what we have for the wiki (Page history)?

comment:3 by Matthew Good, 13 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #1132

comment:4 by Christian Boos, 13 years ago

Keywords: tracobject added; ticket control removed
Resolution: duplicate
Status: closedreopened

Well, I agree that #1132 suggests a possible implementation for this feature.

But strictly speaking, the use of a versioning system backend is not required for being able to version ticket descriptions, which I believe is what was requested here.

Actually the description is already versioned in the ticket_change table, so it could be possible to provide a Ticket History showing the evolution of a ticket description, diffs between version in a way completely similar to the wiki Page History, without the need of #1132

comment:5 by anonymous, 13 years ago

a Ticket History showing the evolution of a ticket description is exactly what i need. the idea is, that if i want to use tickets for my requirements i must be able to a) see the history of the ticket evolution b) diff the history c) be able to recover/display all tickets for a given tag/date with this it should be possible to handle the requirements for a project as tickets with type enhancment.

comment:6 by Christian Boos, 13 years ago

Owner: changed from Jonas Borgström to Christian Boos
Status: reopenednew

Yes, so that's what I thought. Also to be considered here is a Wiki syntax for linking to explicit versions and diffs, similar to what is discussed for Wiki content (see #2635).

As a side note, there's nothing special about ticket type names, you're free to create an explicit requirement ticket type, using either TracAdmin or the WebAdmin plugin.

comment:7 by Russell Hind <rhind@…>, 13 years ago

Cc: rhind@… added

I'd also like to see a full history for a ticket. We don't (yet!) require rollback capabilities, but being able to view the full history would be extremely useful. It would also be able to see actual date times. Currently I have a ticket which says 'Opened 1 year ago' and 'Last modified 2 hours ago'. The '1 year ago' is very vague. At least the yy/mm/dd would be more useful.

Thanks

Russell

comment:8 by Alec Thomas, 13 years ago

Viewing the complete ticket history is now possible in trunk since r3305. Each ticket exports an RSS feed and CSV formats with all changes and full dates.

comment:9 by Matthew Good, 13 years ago

You can see the full date/time for the "1 year ago" by hovering your mouse over the text.

comment:10 by Russell Hind <rhind@…>, 13 years ago

Great, thanks.

Russell

in reply to:  8 comment:11 by Christian Boos, 13 years ago

Replying to athomas:

… Each ticket exports an RSS feed and CSV formats with all changes and full dates.

The RSS feed actually has the all changes, but the CSV format has not, only the current values. Can you please clarify what was intended?

comment:13 by Russell Hind <rhind@…>, 13 years ago

Milestone: 0.5

comment:14 by Christian Boos, 13 years ago

Keywords: history added
Milestone: 0.11
Severity: normalmajor
Status: newassigned

I'm currently working on this. So far I've got the history page. The diff and the ability to view the ticket at a specific version will follow.

in reply to:  14 comment:15 by Russell Hind <rhind@…>, 13 years ago

Replying to cboos:

I'm currently working on this. So far I've got the history page. The diff and the ability to view the ticket at a specific version will follow.

Does this mean that entries such as 'Description Changed' won't show up in the comments from now on?

We currently constantly edit the description for some items which act as a to do list or just have many commits as we put the commit number and cross out done items in the description, but currently this then puts a lot of entries in as comments of just 'Description Changed'

If there is a history page with this information, then could these be removed from the comments (unless a comment is also supplied, then it would be useful to see what changed with that comment).

Cheers

Russell

comment:16 by Christian Boos, 13 years ago

Description Changed is not really part of the comment. It's a special, concise way to display a text field change (the description in this case). So in the description history list, you won't see that, only the comment if given.

in reply to:  16 comment:17 by anonymous, 13 years ago

Replying to cboos:

Description Changed is not really part of the comment. It's a special, concise way to display a text field change (the description in this case). So in the description history list, you won't see that, only the comment if given.

Just to clarify then: So if we modify the description, but don't supply a comment, then there will be no 'comment' for that change as there is at the moment, but the description history will be available via the ticket history you are working on?

That sounds like a really useful feature. 0.11 Looks like it will be an excellent release.

Cheers

Russell

comment:18 by Christian Boos, 13 years ago

Yes. Eventually the Description changed will be augmented by a (diff) link, for showing the actual changes.

comment:19 by Christian Boos, 13 years ago

Resolution: fixed
Status: assignedclosed

Implemented in r4347. Feedback welcomed!

If there's any issue with this new feature, please file a new ticket.

comment:20 by abublic@…, 12 years ago

Just where is it? I'm keen for this but can't see the diff link in my local 0.10.4 nor in http://trac.edgewall.org (0.10.5 dev currently).

comment:21 by anonymous, 12 years ago

As the milestone field says: 0.11

comment:22 by abublic@…, 12 years ago

cool, thanks

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.