Edgewall Software
Modify

Opened 14 years ago

Closed 10 years ago

#1673 closed enhancement (duplicate)

History for milestone description text

Reported by: jornhansen@… Owned by: Christian Boos
Priority: normal Milestone:
Component: roadmap Version: 0.8.2
Severity: normal Keywords: tracobject version history
Cc: jornhansen@…, christiansen.t@…, daved@… Branch:
Release Notes:
API Changes:

Description

It would be nice to have history on the description text for a milestone like what's currently available on wiki pages.

The usage scenario for this is that sometimes you suspect a milestone description has changed since you last looked at it and you start wondering "what was changed - and when?"

Possible extensions:

  • add change information like in wiki pages (user and comment) - this would answer "who changed what when and why".
  • add changes to the timeline also like it works for wiki pages

Attachments (0)

Change History (10)

comment:1 by Christian Boos, 14 years ago

Milestone: 0.9
Owner: changed from Christopher Lenz to anonymous
Severity: normalenhancement
Status: newassigned

comment:2 by Christian Boos, 14 years ago

Owner: changed from anonymous to Christian Boos
Status: assignednew

(forgot to login)

comment:3 by Christian Boos, 14 years ago

Keywords: object added

comment:4 by Christopher Lenz, 14 years ago

Summary: History for roadmap description textHistory for milestone description text

#2521 has been marked as duplicate of this ticket.

comment:5 by Christian Boos, 14 years ago

Keywords: tracobject added; object removed

comment:6 by anonymous, 13 years ago

Cc: daved@… added

comment:7 by Christian Boos, 13 years ago

Keywords: version history added
Milestone: 1.0

Related to #2945.

As opposed to ticket descriptions, there's currently no workaround for getting the previous versions of the milestone description. A change in the datamodel, as outlined in TracDev/Proposals/DataModel is in order for this one.

comment:8 by trac@…, 13 years ago

See also #3776.

comment:9 by anonymous, 10 years ago

It seems like, now that #454 is complete, one could essentially apply the same changes that were made to generate a comment history in order to generate a milestone history. If that is the case, I will probably give it a shot.

in reply to:  9 comment:10 by Christian Boos, 10 years ago

Milestone: 1.0
Resolution: duplicate
Status: newclosed

Replying to anonymous:

It seems like, now that #454 is complete, one could essentially apply the same changes that were made to generate a comment history in order to generate a milestone history. If that is the case, I will probably give it a shot.

Well, no, this has nothing to do with #454, the changes that were made for saving the comment change history for tickets can't be transposed in this situation.

Like explained in comment:7, we don't even store yet the previous versions of a milestone description, so we need some kind of drastic data model change for that, and if we do this, then it can at the same time be the occasion to find a better data model, which could accommodate the wiki, ticket and other resources and precisely remove the need for hacks of the kind of #454

Closing as duplicate of #3776.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.