Edgewall Software
Modify

Opened 13 years ago

Last modified 3 years ago

#1329 new enhancement

Ticket Search should (optionally) search only non-closed tickets

Reported by: Norbert Unterberg <nepo@…> Owned by:
Priority: normal Milestone: next-major-releases
Component: ticket system Version: 0.8.1
Severity: major Keywords: search
Cc: nepo@…, tony.meyer@…, leho@…, Ryan J Ollos
Release Notes:
API Changes:

Description (last modified by Christian Boos)

One of the popular uses for searching (I believe) is to search the ticket database if an issue has already been filed. It would help if the search would only search tickets that have not been closed.

This request is similar to Ticket #584 but I would like a way to filter the results so that only open tickets are displayed in the search result. It does not help much if you need to browse loads of resolved tickets to find the one open ticket you are looking for.

fixed typos

Attachments (0)

Change History (23)

comment:1 Changed 12 years ago by dneary@…

This is a part of ticket #1722 (since closed as invalid).

It would be nice if someone could outline how this could be done - I did look at the template code, but couldn't figure out an easy way to filter on the bug's status. I would be prepared to make the change, if I had some idea how to go about it.

comment:2 Changed 12 years ago by Christian Boos

Component: generalticket system
Description: modified (diff)
Keywords: search added
Milestone: 0.11

My current take on the issue is that there should be a way to "forward" the list of tickets found during a search to the custom query view, where one can add additional criterions to refine the search or better organize the results.

Alternatively, a "free text form search" could be reintroduced on the custom query page.

See related discussion on TracDev:333

comment:3 Changed 10 years ago by Christian Boos

Milestone: 0.11.10.12

#6869 was closed as duplicate.

comment:4 Changed 10 years ago by Christian Boos

Severity: normalmajor

comment:5 Changed 9 years ago by Christian Boos

#7900 was closed as duplicate.

comment:6 Changed 8 years ago by anonymous

Any news on that issue? It's really, really boring having not the capability to do this

comment:7 Changed 8 years ago by Christian Boos

The possibility to forward results to a custom query view (comment:2) was implemented in a branch, this should eventually be revived for (one of the) next major version. See SearchRefactoring#Reuseofresults1.

comment:8 Changed 8 years ago by Remy Blank

Milestone: next-major-0.1Xunscheduled

comment:9 Changed 8 years ago by Ryan J Ollos <ryano@…>

I have exactly the same issue as the reporter of this ticket, which is what led me here. It seems like it would be worthwhile to implement open and closed checkboxes in the interm, even if its not the best long term solution.

This seems like a reasonable sized ticket that I'd be willing to tackle, though the fact that its been open so long makes me wonder if it is more challenging than I anticipate.

comment:10 Changed 8 years ago by Ryan J Ollos <ryano@…>

Cc: ryano@… added

comment:11 Changed 8 years ago by Ryan J Ollos <ryano@…>

Not sure if there is any potential overlap, but #9098 is a feature request for individual Tickets open and closed filters on the timeline.

comment:12 Changed 8 years ago by Remy Blank

Milestone: unscheduled0.13
Owner: changed from Jonas Borgström to Remy Blank

I intended to implement the "throw tickets from a search result list into a ticket query" functionality in #3375, which is actually a duplicate of this ticket. So I'd rather not add a "temporary" solution at this point.

comment:13 Changed 7 years ago by Remy Blank

Milestone: 0.130.14

comment:14 Changed 7 years ago by Remy Blank

#10031 was closed as a duplicate.

comment:15 Changed 7 years ago by tony.meyer@…

Cc: tony.meyer@… added

Alternatively, if the custom query interface allowed a search term as a filter, any number of variations of this would be possible (e.g. open in open tickets, only in closed tickets, only in tickets belonging to X, only in tickets that are in this milestone and open, …).

comment:16 Changed 7 years ago by anonymous

6 years and still there isn't a simple check box to filter open/closed tickets. Obviously the whole search is useless as it is now and needs refactoring but at least this very simple feature will help a lot of people.

comment:17 in reply to:  15 Changed 7 years ago by tony@…

Replying to tony.meyer@…:

Alternatively, if the custom query interface allowed a search term as a filter, any number of variations of this would be possible (e.g. open in open tickets, only in closed tickets, only in tickets belonging to X, only in tickets that are in this milestone and open, …).

Sigh. Somehow I missed that this was already possible. So IMO there's not a great need for this, because it's far better to do a custom query for open tickets with a description/summary term - in fact, a "search" for tickets is almost always the wrong thing to do, and a custom query the right thing (searching is for wiki/changeset/milestone).

comment:18 Changed 6 years ago by axeld

Good luck telling this the average user :-)

comment:19 Changed 5 years ago by lkraav <leho@…>

Cc: leho@… added

comment:20 Changed 5 years ago by anonymous

a simple user maybe doesn't have access to the custom query. the general search is generally the only tool available for him.

comment:22 Changed 4 years ago by Ryan J Ollos

Cc: Ryan J Ollos added; ryano@… removed

comment:23 Changed 3 years ago by Ryan J Ollos

Milestone: next-dev-1.1.xnext-major-releases

Retargetting tickets to narrow focus for milestone:1.2. Please move the ticket back to milestone:next-dev-1.1.x if you intend to resolve it by milestone:1.2.

comment:24 Changed 3 years ago by Ryan J Ollos

Owner: Remy Blank deleted

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned.
as The resolution will be set.
The owner will be changed from (none) to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.