Edgewall Software
Modify

Opened 15 years ago

Closed 11 years ago

#3375 closed enhancement (duplicate)

add contains text option to ticket query, or query restriction possibility to search

Reported by: ThurnerRupert Owned by: Remy Blank
Priority: normal Milestone:
Component: search system Version: devel
Severity: major Keywords: query
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

currently it is difficult to find open tickets containing some search string (text). search does a good job in finding all the tickets (e.g. all tickets having "custom query"), but it would be nice if such a result could be somehow fit into a query too by further restricting it with other filters. also search could offer further restriction possibilities like custom query does.

Attachments (0)

Change History (5)

comment:1 by anonymous, 15 years ago

maybe #1901 is somehow related to this.

comment:2 by Christian Boos, 15 years ago

Keywords: query added
Milestone: 1.0
Severity: normalmajor

I agree that having full text search facilities and then be able to further refine and manipulate the results in a TracQuery way would be a totally awesome killer feature (one more ;) ).

See also #2465.

comment:3 by Christian Boos, 12 years ago

Milestone: 1.0unscheduled

Milestone 1.0 deleted

comment:4 by Remy Blank, 11 years ago

Milestone: triaging0.13
Owner: changed from Jonas Borgström to Remy Blank

This could be done relatively easily by providing a link to the query page on the search results page, passing all ticket IDs in the result list as an ?id= parameter. Keeping it generic and not hardcoding the functionality into the search module is more difficult, though.

Sounds fun, I'll give it a go.

comment:5 by Remy Blank, 11 years ago

Milestone: 0.13
Resolution: duplicate
Status: newclosed

This is actually a duplicate of #1329.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Remy Blank.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Remy Blank to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.