Edgewall Software
Modify

Opened 17 months ago

Last modified 8 months ago

#13019 reopened enhancement

Make dropdowns searchable / filterable

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: web frontend Version:
Severity: normal Keywords: css chosen
Cc: Branch:
Release Notes:
API Changes:

Description

Copied from 10012#comment:82:

About select boxes:

Another interesting library I recently discovered is http://harvesthq.github.com/chosen/

Wow, impressive! Yes, looks like it's a must have.

Any arguments against including it in core?

Not from my side. [cboos]

This would be especially useful for milestone selection. Often there are many milestones and finding a certain milestone can be difficult because they are sorted by due date. Allowing to use the filtering of chosen would be very helpful and nice.

Attachments (3)

add_chosen_v1.8.5.patch (42.1 KB ) - added by anonymous 17 months ago.
use_chosen.patch (2.8 KB ) - added by anonymous 17 months ago.
chosen_milestone.png (34.3 KB ) - added by anonymous 17 months ago.

Download all attachments as: .zip

Change History (13)

comment:1 by Ryan J Ollos, 17 months ago

Resolution: duplicate
Status: newclosed

Please comment in #2130 rather than making more tickets.

by anonymous, 17 months ago

Attachment: add_chosen_v1.8.5.patch added

by anonymous, 17 months ago

Attachment: use_chosen.patch added

by anonymous, 17 months ago

Attachment: chosen_milestone.png added

comment:2 by anonymous, 17 months ago

Sorry, I thought it would be better a new ticket for attaching patches.

Last edited 17 months ago by Ryan J Ollos (previous) (diff)

comment:3 by anonymous, 17 months ago

Instead of sorting the milestones alphabetically, filtering with Chosen can help for finding certain milestone or other field among many.

comment:4 by Jun Omae, 17 months ago

At least, the Chosen jquery plugin doesn't correctly work with Input_method (tested Chosen's demo on my Windows 10 for Japanese locale).

comment:5 by Jun Omae, 17 months ago

Also, you can create Trac plugin to apply Chosen jquery plugin rather than change Trac core.

Last edited 17 months ago by Ryan J Ollos (previous) (diff)

comment:6 by anonymous, 17 months ago

On Chosen's GitHub there's an open issue about IME with IE.

in reply to:  5 comment:7 by anonymous, 17 months ago

Replying to Jun Omae:

Also, you can create Trac plugin to apply Chosen jquery plugun rather than change Trac core.

Alright. I thought it was maybe desired in Trac core:

Replying to Remy Blank:

Replying to cboos:

Replying to lkraav <leho@…>:

Any arguments against including it in core?

Not from my side.

Not from mine either, it definitely looks nice.

in reply to:  2 ; comment:8 by Ryan J Ollos, 17 months ago

Replying to anonymous:

Sorry, I thought it would be better a new ticket for attaching patches.

I misunderstood. The ticket is not related to #2130.

select2 is another possibility that I've experimented yet. I think we should add the feature to the Trac core, but I don't want to do piecemeal changes of the user interface. It should instead be done as part of a user-interface facelift. If you don't want to wait for us to get around to that, the plugin is a good route to getting the feature in your Trac instance soon. See also #10012, MultiSelectFieldPlugin.

I don't want to discourage contributions, but the fact is that the TracTeam needs to put a considerable amount of effort to adopt changes like this. Currently we are focused on other things in our limited time. We'd welcome contributions on less-extensive changes though (see bitesized tickets).

in reply to:  8 comment:9 by anonymous, 16 months ago

Keywords: css chosen added
Resolution: duplicate
Status: closedreopened

Replying to Ryan J Ollos:

I misunderstood. The ticket is not related to #2130.

So not a duplicate of that ticket → reopening.

comment:10 by anonymous, 8 months ago

Similar request in th:ticket:13529 pointing to https://github.com/jun66j5/tracselectboxplugin using select2.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The ticket will remain with no owner.
The ticket will be disowned. Next status will be 'new'.
as The resolution will be set. Next status will be 'closed'.
The owner will be changed from (none) to anonymous. Next status will be 'assigned'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.