Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

#12068 closed enhancement (duplicate)

Move changeset search provider to cache.py

Reported by: Ryan J Ollos Owned by:
Priority: lowest Milestone:
Component: version control/changeset view Version:
Severity: normal Keywords: search
Cc: mmitar@… Branch:
Release Notes:
API Changes:

Description

It was suggested in #9485 that the changeset search provider should be moved to trac/versioncontrol/cache.py since only cached repositories are searched.

The ISearchSource implementation currently exists in tags/trac-1.1.4/trac/versioncontrol/web_ui/changeset.py@:1114#L1112.

Attachments (1)

t12068-search-changesets.diff (4.6 KB ) - added by Jun Omae 4 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 by Mitar, 4 years ago

Cc: mmitar@… added

comment:2 by Ryan J Ollos, 4 years ago

Priority: normallowest

comment:3 by Ryan J Ollos, 4 years ago

Also, the Changeset search filter should only be visible when at least one cached repository exists.

by Jun Omae, 4 years ago

comment:4 by Jun Omae, 4 years ago

I think it might be good to add search_changesets method to Repository class and ChangesetModule.get_search_results() be implemented using the method of each repository. See t12068-search-changesets.diff.

After the patch, I think we could implement it using git log --all --all-match --grep=PATTERN for git repository without cache.

Thoughts?

comment:5 by Ryan J Ollos, 4 years ago

That looks like a nice change to make.

comment:6 by Ryan J Ollos, 4 years ago

Milestone: next-major-releases
Resolution: duplicate
Status: newclosed

Turns out there was already a ticket for this, so closing as a duplicate of #10764.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.