Edgewall Software
Modify

Opened 5 years ago

Closed 4 years ago

#12067 closed defect (duplicate)

TracBatchModify does not permit changes to resolution nor permit avoiding sending emails

Reported by: shane@… Owned by:
Priority: normal Milestone:
Component: general Version: 1.0.4
Severity: normal Keywords: batch
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Ryan J Ollos)

The old BatchModifyPlugin BatchModifyPlugin plugin (prior to 1.0) had a couple of nifty features:

  1. You could indicate whether you wanted email notifications to be sent at all as a result of the change.
  2. You could make a change to the 'resolution' field even when the items were already 'closed'.

Currently, it appears as if the TracBatchModify component explicitly prohibits the modification of the resolution field. It also seems to only offer the setting of an explicit resolution if the current resolution is NOT set to 'closed'.

In addition, there is no way to tell the system to skip sending an email.

I would like to be able to batch modify the resolution at any time.

Two use cases:

  1. Our workflow here is to set the resolution to 'fixed' when the developer is done, 'closed' when it has been merged and tested, and then migrate to 'shipped' when it has been included in a release. Right now this is impossible via batch so we need to hand-convert each closed and shipped item. That's a LOT of clicking.
  1. We often want to quietly shift a bunch of items from one milestone to another. Since there is no way to disable notification emails, right now this will tell each reported and CC that their item has been deferred.

I am happy to provide a patch for both of these if people think it would be useful.

Attachments (0)

Change History (4)

comment:1 by Ryan J Ollos, 5 years ago

Description: modified (diff)

in reply to:  description comment:2 by Ryan J Ollos, 5 years ago

Replying to shane@…:

Currently, it appears as if the TracBatchModify component explicitly prohibits the modification of the resolution field. It also seems to only offer the setting of an explicit resolution if the current resolution is NOT set to 'closed'.

The resolution field is managed through the TracTicketWorkflow. You can modify the resolution by adding a workflow action:

set_resolution = closed -> closed
set_resolution.operations = set_resolution
set_resolution.permissions = TICKET_BATCH_MODIFY

comment:3 by anonymous, 5 years ago

That's awesome! I am still interested in having a flag that can disable the sending of notification emails on a change, but that is not nearly as critical.

comment:4 by Ryan J Ollos, 4 years ago

Resolution: duplicate
Status: newclosed

It might be worthwhile to add the workflow action from comment:2 to the default workflow.

Disabling notifications has also been requested in #8607, and th:QuietPlugin implements the behavior for th:AnnouncerPlugin. You are correct that the behavior was implemented for BatchModifyPlugin: th:browser:/batchmodifyplugin/0.12/trunk/batchmod/templates/batchmod.html@8826:40-41#L38.

I've previously request the behavior in #11535, which was closed as a duplicate of #8607. We'd welcome contributions if you'd like to work on #8607. Ideally this would be implemented on the trunk, where AnnouncerPlugin is being integrated.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.