Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11373 closed defect (duplicate)

some wiki markup produces broken/invalid html, breaks preview, breaks ticket saving

Reported by: lp-san@… Owned by: Jun Omae
Priority: normal Milestone:
Component: wiki system Version: 1.0.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Possible error in wiki markup processing in Trac 1.0.1.

How to reproduce: place the following markup in ticket description:

3. test header
''test text.
test text''

Results: 1) this code transforms to broken html:

    <div class="searchable">
      <ol start="3"><li>test header
</em></li></ol><p>
<em>test text.<br />
test text<em> 2<br />
</em></p>

    </div>

it's completely not well-formed (EM tags are messed up)

2) when updating live-preview, jQuery silently fails to parse data containing this broken markup

3) due to 2, jQuery fails to update ticket draft

4) due to 2, jQuery completely removes the view_time hidden element from the ticket form here:

$("#propertyform input[name='view_time']").replaceWith(items.filter("input[name='view_time']"));

, effectively triggering the error when saving such ticket: Sorry, can not save your changes. This ticket has been modified by someone else (because req.args.get('view_time') is None in trac/ticket/web_ui.py).

Reproduced on demo site: http://trac.edgewall.org/demo-1.0/ticket/2503

Attachments (0)

Change History (6)

comment:1 by Jun Omae, 9 years ago

Component: generalwiki system
Milestone: next-stable-1.0.x

Thanks for the reporting! 0.12-stable has the same issue.

comment:2 by Jun Omae, 9 years ago

Milestone: next-stable-1.0.x0.12.6
Owner: set to Jun Omae
Status: newassigned

Proposed fix can be found in log:jomae.git:ticket11373_0.12.6dev.

comment:3 by lp-san@…, 9 years ago

jomae, thanks a lot for a quick fix!

comment:4 by Jun Omae, 9 years ago

Resolution: duplicate
Status: assignedclosed

I found the same issue has been reported in #11009. Also, the proposed changes were not enough to fix it.

comment:5 by Ryan J Ollos, 9 years ago

Milestone: 0.12.6

in reply to:  4 comment:6 by lp-san@…, 9 years ago

Replying to jomae:

I found the same issue has been reported in #11009. Also, the proposed changes were not enough to fix it.

The fix you proposed seems to help my case. Thanks anyway, I'll watch the other ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.