Edgewall Software
Modify

Opened 6 years ago

Last modified 3 years ago

#11372 new enhancement

sort for owner shall be case-insensitive

Reported by: alexander.stohr@… Owned by:
Priority: normal Milestone: next-stable-1.2.x
Component: query system Version: 1.0.1
Severity: normal Keywords:
Cc: alexander.stohr@…, Ryan J Ollos Branch:
Release Notes:
API Changes:

Description

for an existing installation of TRAC the mail gateway for owner & similar entries works seemingly fine by auto-adding the mail domain to the provided credentials regardless of upper & lowercase variants as e-mail adresses are case in-sensitive. but when doing a web interface query like for active tasks and then clicking "Owner" for sorting the results by name its the case that John.Doe is differently sorted in that listing than john.doe and thus it needs always at least two checks of the list contents to get the entries for both of these name variants. (more variations are thinkable, even camel case…)

Attachments (0)

Change History (5)

comment:1 by Jun Omae, 6 years ago

Component: web frontendquery system
Milestone: 1.0.2
Resolution: duplicate
Status: newclosed

A duplicate of #5720.

comment:2 by Jun Omae, 6 years ago

Milestone: next-stable-1.0.x
Resolution: duplicate
Status: closedreopened

Sorry about my mistake. #5720 is case-insensitive matching in query system. But this is case-insensitive sorting in query system.

comment:3 by Ryan J Ollos, 6 years ago

Cc: Ryan J Ollos added

I suppose email addresses should always be case insensitive in the sort, but whether or not login names are treated as case sensitive might depend on the trac: ignore_auth_case setting.

comment:4 by Ryan J Ollos, 4 years ago

Status: reopenednew

comment:5 by Ryan J Ollos, 3 years ago

Milestone: next-stable-1.0.xnext-stable-1.2.x

Moved ticket assigned to next-stable-1.0.x since maintenance of 1.0.x is coming to a close. Please move the ticket back if it's critical to fix on 1.0.x.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned. Next status will be 'new'.
as The resolution will be set. Next status will be 'closed'.
The owner will be changed from (none) to anonymous. Next status will be 'assigned'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.