Edgewall Software
Modify

Opened 16 years ago

Last modified 5 years ago

#1069 new enhancement

query by example (e.g. when creating a new ticket, check for similar tickets)

Reported by: Christian Boos Owned by:
Priority: lowest Milestone: next-major-releases
Component: ticket system Version: 0.8
Severity: normal Keywords: new ticket duplicate dedupe
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

There could be some ways to reduce the amount of duplicate tickets getting created. The simplest way would be to advertise doing a search:

E.g (any better english is welcome, of course):

Create New Ticket

Have you checked that the issue you want to report was not already raised before? If not, please Search for existing tickets describing your problem before creating a new one.

Your email or username: …


A more sophisticated way would be to do a search (in the tickets) based on the content of the Short summary field and the Keywords field, when the reporter Previews his new ticket. The result of the search would also appear on the ticket preview page. From that point, the reporter could choose either to go on with the creation of his new ticket (maybe clarifying what distinguishes it from other, similar tickets), or to contribute to existing similar tickets if some are found and relevant for him.

Attachments (1)

search_for_similar_tickets_r3013.diff (2.9 KB ) - added by Christian Boos 14 years ago.
Adds a Search Similar… button in the new ticket page, that redirects to an adequate custom query

Download all attachments as: .zip

Change History (18)

comment:1 by Christopher Lenz, 16 years ago

Keywords: dedupe added

I agree, automatically searching for dupes would be cool.

comment:2 by Matthew Good, 15 years ago

#1595 has been marked as a duplicate of this ticket

comment:3 by Gunnar Wagenknecht <gunnar@…>, 15 years ago

Cc: gunnar@… added

The feature would be nice but should be optional. I didn't like the feature when working with Scarab. In 80% of the case the found duplicates were absolutly unrelated to the entered ticket. Looks like the search algorithm needs a lot attention for such a feature.

by Christian Boos, 14 years ago

Adds a Search Similar… button in the new ticket page, that redirects to an adequate custom query

comment:4 by Christian Boos, 14 years ago

Milestone: 0.10
Owner: changed from Jonas Borgström to Christian Boos
Status: newassigned

What about using the newticket form as an alternative way to prepare a custom ticket query?

See attachment:search_for_similar_tickets_r3013.diff

The above patch also adds the possibility to search for the Description field in the query page.

comment:5 by Alex Buccino <alexander.buccino@…>, 14 years ago

The utility of this feature really hinges on your definition of "similar". I've done some work in document similarity analysis and I would love to see something like that in Trac. However, to have real utility, I think it would need to be built on a probablistic search engine, like Xapian. Roundup is using this search library, but I don't think it has a "find similar" function.

comment:6 by Christian Boos, 14 years ago

Milestone: 0.100.11
Owner: changed from Christian Boos to Alec Thomas
Status: assignednew

It seems that Alec has started something like this in the WorkFlow branch (see r3111). My approach was more a kind of query by example

comment:7 by Alec Thomas, 14 years ago

The similarity detection is now exposed as a plugin interface, so it can be extended. The default one is basic.

comment:8 by anonymous, 14 years ago

Cc: gunnar@… removed

comment:9 by Christian Boos, 13 years ago

Owner: changed from Alec Thomas to Christian Boos

#2775 was a similar request for existing tickets. The patch could be easily adapted to allow for that. I'll look into making an updated version of the patch.

comment:10 by Christian Boos, 13 years ago

Instead of "Search Similar" which has the connotation of requiring advanced AI (as in alect proposal), this could be renamed e.g. "Build Query from Ticket"…

comment:12 by Christian Boos, 12 years ago

Milestone: 0.11.22.0
Summary: When creating new tickets, provide a way to check for similar ticketsquery by example (e.g. when creating a new ticket, check for similar tickets)

This could be done as a plugin (similar to the clone ticket one + the _do_search in attachment:search_for_similar_tickets_r3013.diff).

comment:13 by Christian Boos, 11 years ago

#8096 was closed as duplicate.

comment:14 by Christian Boos, 10 years ago

Milestone: 2.0unscheduled

Milestone 2.0 deleted

comment:15 by Christian Boos, 10 years ago

Milestone: triagingnext-major-0.1X
Priority: normallowest

comment:16 by Ryan J Ollos, 5 years ago

Owner: Christian Boos removed

comment:17 by Ryan J Ollos, 5 years ago

Reporter: changed from cboos@… to Christian Boos

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned.
as The resolution will be set. Next status will be 'closed'.
The owner will be changed from (none) to anonymous. Next status will be 'assigned'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.