Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#9866 closed defect (worksforme)

More as 19+1( empy ) components

Reported by: anonymous Owned by:
Priority: highest Milestone:
Component: report system Version: 0.12-stable
Severity: normal Keywords: needinfo
Cc: support@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

1) Admin - > Components → I have here 4 components. C1, C2, C3, C4. I add new components from C5 to C23. 2) View Tickets→ Custom query I add filter by component and open list box with components list. I see components from C1 to C4. I press Ctrl+F5 in browser ( FF 3.6 ), open list box and I see only 20 components in the list. I can add new components, but each the time I will see first 20 ( first is empty ) and 19 from my list.

Attachments (0)

Change History (16)

comment:1 by Remy Blank, 11 years ago

Could you please make sure that the user under which your Trac installation is running (most probably your web server) has write permission to trac.ini?

comment:2 by anonymous, 11 years ago

yes -rw———- 1 www-data www-data 4639 2010-11-22 13:50 trac.ini and in menu 'Create New Ticket' I see the whole list of components with normal vertical scroll bar. And in Cusom Query combobox never had verticall scroll bar.

comment:3 by anonymous, 11 years ago

I reproduced this bug to reducing number of components. I removed some from the list. Admin panel and 'Create New Ticket' shows me correct list, but 'Custom Query' menu shows me obsolete list of components and CTRL+F5 button doesn't help to refresh it.

comment:4 by Remy Blank, 11 years ago

Does your web server also have write permission to the directory containing trac.ini? What happens if you restart the web server after a change?

comment:5 by anonymous, 11 years ago

yes, there is permission too. and if I reboot apache, correct list will appear.

comment:6 by Remy Blank, 11 years ago

So this looks like a caching issue. Can you please execute the following SQL before and after adding a new component, and post the results here:

SELECT * FROM cache;

comment:7 by Christian Boos, 11 years ago

+ please mention the DB you're using; if it's MySQL, provide some more details (which db engine in particular)

comment:8 by anonymous, 11 years ago

agilo.ticket.api.AgiloTicketSystem.fields|44 sqlite> select * from cache; trac.wiki.api.WikiSystem.pages|56 agilo.ticket.api.AgiloTicketSystem.fields|49 sqlite> select * from cache; trac.wiki.api.WikiSystem.pages|56 agilo.ticket.api.AgiloTicketSystem.fields|52

comment:9 by Remy Blank, 11 years ago

Cc: support@… added
Keywords: needinfo added

Interesting. So you are using AgiloForScrum, which seems to subclass TicketSystem. The cache generation count seems to increment correctly, but the fields aren't refreshed correctly.

The invalidation works correctly AFAICT with a stock Trac, so this must be at least related to Agilo. I don't know if it's an issue in Agilo itself, or something that we should fix in core, so I'm adding the Agilo guys in CC, hopefully they can comment on this issue.

comment:10 by Martin Häcker <martin.haecker@…>, 11 years ago

Not sure if I can help here - we had some problems with caches not being invalidated correctly in the past so this might be an issue - especially since our support for Trac 0.12 is quite new and not considered stable by us yet.

One thing you could try is to go to Admin > Agilo > General and just press save there (without changing anything). We've got a hook there that *should* clear out all caches related to Agilo (and Trac) to help us debug these kind of issues.

I think this might help as you report that restarting the web server seems to help.

comment:11 by anonymous, 11 years ago

Strange thing for this test db Agilo disabled completely. Let me deinstall it and I will try to reproduce bug again and btw, could you pls explain, is it possible don't use Agilo for some of the instances of Trac, or I Agilo replays core anyway, if I just install it.

comment:12 by anonymous, 11 years ago

I removed Agilo egg from Trac and I can not reproduce this bug anymore, you can close it as wrong ticket.

comment:13 by Remy Blank, 11 years ago

Resolution: worksforme
Status: newclosed

Thanks for the feedback. So this may be due to having Agilo installed but disabled.

comment:14 by Martin Häcker <martin.haecker@…>, 11 years ago

Somehow all comments I try to write to this ticket are rejected as spam due to Spam-Bayes analysis. @trac-admins whats up?

comment:15 by Remy Blank, 11 years ago

Sorry about that, our bayes filter needs better training. I have pasted your first message below:

@anonymous: If you serve multiple environments off of one python interpreter, since it only has one namespace, loading a plugin in one environment will make all monkeypatching available to all environments.

Agilo takes great care to make sure that it doesn't interfere with other environments, but of course bugs can happen and we'd love to hear about them so we can fix them.

comment:16 by Martin Häcker <martin.haecker@…>, 11 years ago

Thanks rblank!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.