Edgewall Software
Modify

Opened 12 years ago

Closed 6 years ago

#8966 closed enhancement (duplicate)

restrict_reporter option

Reported by: vincentb1981@… Owned by:
Priority: normal Milestone:
Component: ticket system Version:
Severity: normal Keywords: reporter field bitesized
Cc: felix.schwarz@…, walty8@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Ryan J Ollos)

As for the owner (when restrict_owner = true), it would be nice to be able to select the value of the 'reporter' field from a dropdown list.

This option should come along with a permission setting allowing only a given set of users to report tickets on 'behalf' of other users.

Along the dropdown list, the free input field should remain (useful for anonymous/unregistered users).

Multiple reporters might be allowed, however this would be redundant with Cc. Literature: Existing dropdown list for 'Owner': TracTickets#Assign-toasDrop-DownList

Proposed fullname list (in addition to usernames): #3807

Proposed multiple owner feature: #918

Attachments (0)

Change History (14)

comment:1 by Remy Blank, 12 years ago

I'm not sure how useful this would be. Do you have a concrete use case?

comment:2 by vincentb1981@…, 12 years ago

We use it as an issue tracker for our sysadmin management: a user tells us, in the real life (she/he comes in the office or we meet the user in the corridor ;-), not trough Trac), she/he has an issue then I fill for her/him a Ticket.

The point is we'd like to associate the user as a reporter to this ticket. We don't have an easy way to guess the trac username of the user. Consequently, a dropdown list could be really helpful (for admins).

comment:3 by Christian Boos, 12 years ago

Keywords: reporter field added
Milestone: next-major-0.1X

Maybe an item for FieldRefactoring (somehow related to #4374 and #4549).

comment:4 by Felix Schwarz, 11 years ago

Cc: felix.schwarz@… added

comment:5 by Ryan J Ollos, 6 years ago

Description: modified (diff)
Keywords: bitesized added
Summary: reporter_restrict optionrestrict_reporter option

comment:6 by Ryan J Ollos, 6 years ago

This would also be useful for restricting the reporter filter on the TracQuery page.

comment:7 by walty <walty8@…>, 6 years ago

Cc: walty8@… added

comment:8 by walty <walty8@…>, 6 years ago

while a drop down list is relatively easy to be generated, I wonder how the permission system (that's mentioned in the ticket) is going to work?

in reply to:  description comment:9 by Ryan J Ollos, 6 years ago

Replying to vincentb1981@…:

This option should come along with a permission setting allowing only a given set of users to report tickets on 'behalf' of other users.

This is already implemented. The TRAC_ADMIN permission is required to set the reporter for a ticket. If TICKET_CREATE is granted to anonymous, users can set the reporter field when creating a ticket: tags/trac-1.1.6/trac/ticket/templates/ticket.html@:196,199#L195

Any improvements to the existing behavior would likely be handled by the proposal TracDev/Proposals/EvenFinerGrainedPermissions.

comment:10 by walty <walty8@…>, 6 years ago

So, if I understand correctly, the restrict_reporter option should be something very similar to restrict_owner.

two further questions here:

  1. for existing restrict_owner, I found that the candidate owners (the names in the dropdown list) all need to have the TICKET_MODIFY permission. So I suppose for restrict_reporter, the candidates should have the TICKET_CREATE permission, is that correct?
  1. I found that restrict_owner actually has some interactions with the workflow (set_owner), would restrict_reporter have the same complications?

thanks.

in reply to:  10 comment:11 by Ryan J Ollos, 6 years ago

Replying to walty <walty8@…>:

  1. for existing restrict_owner, I found that the candidate owners (the names in the dropdown list) all need to have the TICKET_MODIFY permission. So I suppose for restrict_reporter, the candidates should have the TICKET_CREATE permission, is that correct?

The reason for restricting ticket owners to those with TICKET_MODIFY is to ensure the user has sufficient permissions to act on the ticket. Most of the workflow actions require TICKET_MODIFY. It wouldn't be very effective in most circumstances to have a ticket owned by a user that can't perform any actions on the ticket.

In the case of restricting the reporter, the reporter doesn't need to perform any actions, so it would seem we should allow a user with TICKET_ADMIN to assign the ticket to any valid user.

  1. I found that restrict_owner actually has some interactions with the workflow (set_owner), would restrict_reporter have the same complications?

With the changes that have been implemented on the trunk, the workflow mostly controls the owner field (comment:60:ticket:2045). To change the owner you perform a workflow action. On the other hand the workflow doesn't act on the reporter field, and the reporter field is similar to other ticket properties. This could change in the future, but so far I don't see a motivation for having the reporter controlled by the workflow.

in reply to:  2 comment:12 by Ryan J Ollos, 6 years ago

Replying to vincentb1981@…:

The point is we'd like to associate the user as a reporter to this ticket. We don't have an easy way to guess the trac username of the user. Consequently, a dropdown list could be really helpful (for admins).

It might be better to pursue the solution in #7628 rather than this ticket, particularly if the aim is to just assist the user in completing the field rather than restrict the entry. Also, #7628 would be very valuable after the changes in #7339 are committed (comment:106:ticket:7339).

Let me know what you think; maybe we can just close this ticket.

Last edited 6 years ago by Ryan J Ollos (previous) (diff)

comment:13 by walty <walty8@…>, 6 years ago

no problem, I would take a look of #7628 then.

comment:14 by Ryan J Ollos, 6 years ago

Milestone: next-major-releases
Resolution: duplicate
Status: newclosed

Closing as a duplicate of #7628.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.