Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#8621 closed enhancement (duplicate)

Use TicketChangeListener infrastructure for ticket notifications

Reported by: Felix Schwarz <felix.schwarz@…> Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.12dev
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Currently the ticket notification system is completely separate from the TicketChangeListener infrastructure so that the notification code needs to be duplicated everywhere if the user should be notified of a change.

The general consensus seems to be that the notification system needs to be cleaned up so this could be the first step in that direction:

Attachments (2)

8621_use_ticket_change_listeners_for_ticket_notifications (15.3 KB ) - added by Felix Schwarz <felix.schwarz@…> 13 years ago.
8621_use_ticket_change_listeners_for_ticket_notifications_cleanup (20.2 KB ) - added by Felix Schwarz <felix.schwarz@…> 13 years ago.
This is an additional cleanup patch which just refactors the code a bit

Download all attachments as: .zip

Change History (5)

by Felix Schwarz <felix.schwarz@…>, 13 years ago

comment:1 by Remy Blank, 13 years ago

Looks like a good start. One issue I can see is that with the patch, a component that changes a ticket cannot prevent sending notifications. For example, the commit_ticket_updater plugin in multirepos has a configuration option to allow not sending notifications for changes due to automatic ticket updates from commit messages.

by Felix Schwarz <felix.schwarz@…>, 13 years ago

This is an additional cleanup patch which just refactors the code a bit

in reply to:  1 comment:2 by Felix Schwarz <felix.schwarz@…>, 13 years ago

Replying to rblank:

Looks like a good start. One issue I can see is that with the patch, a component that changes a ticket cannot prevent sending notifications. For example, the commit_ticket_updater plugin in multirepos has a configuration option to allow not sending notifications for changes due to automatic ticket updates from commit messages.

This is indeed a problem. My feeling is that we need probably additional infrastructure in the TicketNotificationSystem or NotificationSystem so that external plugins can temporarily disable email notifications. The other option would be that you pass additional flags in ticket.save_changes and handle listeners differently which I don't like.

Any suggestions?

comment:3 by Remy Blank, 13 years ago

Resolution: duplicate
Status: newclosed

This is actually a duplicate of #7758, and the issue in comment:1 is also discussed there.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.