Edgewall Software
Modify

Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#8311 closed enhancement (duplicate)

Ability to view and modify final cc list

Reported by: archon810@… Owned by: Emmanuel Blot
Priority: normal Milestone:
Component: notification Version: none
Severity: normal Keywords: cc, notify
Cc: Branch:
Release Notes:
API Changes:

Description

We use trac at my company for our internal bug tracking, wiki, svn integration, etc and I love it.

Having used it for about 3 years, the biggest gripe I keep getting, as an admin, is that essentially once you comment on a ticket, you will keep getting emails till its death.

The configuration is set to 'true' for all the 'always_notify' fields because most of the time, that is what's wanted. However, in certain cases, one of the earlier commenters no longer needs to receive updates but there's no known method of removing him/her from cc.

For example, a ticket starts and gets sent to designers for a logo design. Afterwards, it starts getting bounced around the devs, but designers no longer have any interest in the ticket, yet they keep getting emails to no end.

What would be ideal is if there was an ability for admins to see the final list of recepients, after all owners', reporters', commenters', and people on regular cc list's emails have been aggregated, ready for emailing. The admin would then be able to remove some of those emails from the ticket for users who don't want to receive notifications anymore.

Internally, it would probably work more like a blacklist, per ticket.

I did look at some other tickets here, like #1459 and #4056 but they all deal with a different aspect and granularity of the problem. I welcome any discussion and brainstorming on how to make this the best user experience.

Thank you,
Artem
http://beerpla.net

Attachments (0)

Change History (10)

comment:1 by Christian Boos, 11 years ago

Milestone: 0.13

Sounds to be a legitimate request, however I'm a bit clueless about how to handle it.

Keeping track of it by associating to the other notification requirements (piling up!).

comment:2 by ebray, 11 years ago

I think it would make more sense to allow users to "subscribe" to ticket, and to unsubscribe any time. Settings like always_notify_updater, if set, would just automatically add updaters to the subscription list. They would still be allowed to unsubscribe themselves at any time.

The CC field itself would contain everyone subscribed to that ticket, whether automatically, or manually added to the CC field. Users with the TICKET_EDIT_CC permission would thus have the power to "subscribe" or "unsubscribe" anyone from the ticket.

In other words, not too different from how the CC field currently works. The only difference is that the always_notify_* options will explicitly add users to the CC field.

in reply to:  2 ; comment:3 by Remy Blank, 11 years ago

Replying to ebray:

I think it would make more sense to allow users to "subscribe" to ticket, and to unsubscribe any time. Settings like always_notify_updater, if set, would just automatically add updaters to the subscription list. They would still be allowed to unsubscribe themselves at any time.

+1, excellent idea. We just have to be careful that a user who unsubscribes from a ticket CC doesn't get re-added at the same time due to always_notify_updater.

comment:4 by Artem Russakovskii <archon810@…>, 11 years ago

I like the idea, however it's executed, as long as it allows for one-time operations, like removals, per ticket.

in reply to:  3 ; comment:5 by ebray, 11 years ago

Replying to rblank: We just have to be careful that a user who unsubscribes from a ticket CC doesn't get re-added at the same time due to always_notify_updater.

Good point. Not sure exactly how you'd want to handle that… Maybe an additional hidden field for users/email addresses that have been explicitly unsubscribed? Not sure I like that, but I don't have any better ideas at the moment.

in reply to:  5 comment:6 by Remy Blank, 11 years ago

Replying to ebray:

Good point. Not sure exactly how you'd want to handle that… Maybe an additional hidden field for users/email addresses that have been explicitly unsubscribed? Not sure I like that, but I don't have any better ideas at the moment.

Another idea: when always_notify_updater is true, and the user doesn't have TICKET_EDIT_CC, we could set the "Add/remove from CC" checkbox by default. So if the user doesn't do anything special, she is automatically added to the CC list at the first comment. If she wants to unsubscribe, she just has to un-check the box.

No idea how to handle users who have TICKET_EDIT_CC, though…

comment:7 by Chris Smith <me@…>, 10 years ago

+1 for unsubscribe. Great idea.

About 50% of my ticket traffice is from tickets that no longer concern me.

comment:8 by Ryan Ollos <ryano@…>, 10 years ago

There is a SubscriberListPlugin that shows which users are subscribed to a ticket. I haven't used it, but it looks nice.

comment:9 by Christian Boos, 9 years ago

Milestone: next-major-0.1X
Resolution: duplicate
Status: newclosed

Duplicate of #9971 (short term fix) / #8677 (longer term solution).

comment:10 by Christian Boos, 9 years ago

Also, about "the ability to view the final CC:" list, see #8094.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Emmanuel Blot to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.