Edgewall Software
Modify

Opened 12 years ago

Closed 10 years ago

#8002 closed defect (worksforme)

Trac mail looks spammy to SpamAssassin

Reported by: jidanni@… Owned by: Emmanuel Blot
Priority: low Milestone:
Component: notification Version: none
Severity: minor Keywords:
Cc: sylvain@…, Thijs Triemstra Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Just a heads up: did you ever run a Trac notification email thru SpamAssassin?

X-Spam-Status: … tests=MISSING_HEADERS,ANY_BOUNCE_MESSAGE,BOUNCE_MESSAGE

The MISSING_HEADERS is because you and most Trac installations don't include a To:. Legal, but "acting like a spammer".

The BOUNCE_MESSAGE stuff is due to something about edgewall's Trac that is triggering SpamAssassin/Plugin/VBounce.pm in some way over my head.

Attachments (0)

Change History (7)

comment:1 by Christian Boos, 12 years ago

Milestone: 0.13

There's effectively no To: header set.

in reply to:  1 ; comment:2 by Emmanuel Blot, 12 years ago

Replying to cboos:

There's effectively no To: header set.

It is set if you enable use_public_cc (I know, the option name is all but well chosen)
It you ask Trac to hide destination email addresses, then To: header is not emitted.

comment:3 by Sylvain <sylvain@…>, 11 years ago

Cc: sylvain@… added

in reply to:  2 comment:4 by cb <christop@…>, 10 years ago

Replying to eblot:

Replying to cboos:

There's effectively no To: header set.

It is set if you enable use_public_cc (I know, the option name is all but well chosen)
It you ask Trac to hide destination email addresses, then To: header is not emitted.

On a Debian Lenny with trac-0.11.1 it does not work. For having a To: header you need trac-0.12, right?

comment:5 by Thijs Triemstra <lists@…>, 10 years ago

Cc: lists@… added

comment:6 by Thijs Triemstra, 10 years ago

Cc: Thijs Triemstra added; lists@… removed
Priority: lowestlow
Severity: trivialminor

On a fresh trac installation I'm not able to reproduce this, and the ticket report doesn't tell you how to reproduce it..

On 0.12-stable spamassassin --test-mode < trac-0.12-notification-email.txt adds the following headers indicating it's not spam:

X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on collab-mactel.local
X-Spam-Level: 
X-Spam-Status: No, score=0.0 required=5.0 tests=none autolearn=unavailable
	version=3.3.1

comment:7 by Remy Blank, 10 years ago

Milestone: next-major-0.1X
Resolution: worksforme
Status: newclosed

Let's close this, then.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Emmanuel Blot to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.