Edgewall Software
Modify

Opened 14 years ago

Closed 12 years ago

#7692 closed defect (worksforme)

Unable to view tickets with long descriptions in the timeline or individually

Reported by: octo@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.11.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

My Trac installation recently gained some new tickets with extremely long descriptions. Any attempt to view the tickets individually or in the timeline view results in errors (see below for specific messages).

I'm running a configuration using the following versions:

  • Trac: 0.11.1
  • DB: PostgreSQL 8.1.5
  • Python: 2.3.5 (on Solaris 10)
  • Webserver: lighttpd/fastcgi proxy'd through Apache.

Timeline view:

2008-10-03 21:03:50,617 Trac[web_ui] ERROR: Timeline event provider TicketModule failed
Traceback (most recent call last):
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/timeline/web_ui.py", line 160, in process_request
    filters):
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/ticket/web_ui.py", line 307, in get_timeline_events
    (ts_start, ts_stop))
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
ProgrammingError: t receive data from server: Transport endpoint is not connected

Individually:

2008-10-03 21:04:58,049 Trac[main] ERROR: t receive data from server: Transport endpoint is not connected
Traceback (most recent call last):
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/web/main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/ticket/web_ui.py", line 170, in process_request
    return self._process_ticket_request(req)
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/ticket/web_ui.py", line 435, in _process_ticket_request
    ticket = Ticket(self.env, id, version=version)
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/ticket/model.py", line 47, in __init__
    self._fetch_ticket(tkt_id, db)
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/ticket/model.py", line 95, in _fetch_ticket
    % ','.join(std_fields), (tkt_id,))
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/software/python-2.3.5/lib/python2.3/site-packages/Trac-0.11.1-py2.3.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
ProgrammingError: t receive data from server: Transport endpoint is not connected

A psql dump of a ticket that causes the error is attached.

Attachments (1)

long-ticket.txt (32.8 KB ) - added by octo@… 14 years ago.
Ticket with a very long description

Download all attachments as: .zip

Change History (4)

by octo@…, 14 years ago

Attachment: long-ticket.txt added

Ticket with a very long description

comment:1 by Remy Blank, 14 years ago

Milestone: 1.0

Anybody using PostgreSQL feels like trying to reproduce the problem?

comment:2 by Christian Boos, 12 years ago

Milestone: 1.0unscheduled

Milestone 1.0 deleted

comment:3 by Remy Blank, 12 years ago

Milestone: triaging
Resolution: worksforme
Status: newclosed

I can't reproduce the issue here with Trac 0.12, PostgreSQL 8.3.11, Python 2.6. I have pasted long-ticket.txt four times into a ticket description, and everything works fine. So this might be an InstallationIssue, or a bug in the versions you are using. Please try to upgrade.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.