Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#7614 closed defect (duplicate)

Cannot login

Reported by: kalaz@… Owned by:
Priority: high Milestone:
Component: general Version: 0.11-stable
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

hi, i can't login to my trac because of the following error. I am using IIS to deploy trac.

Traceback (most recent call last):
  File "C:\Python25\Lib\site-packages\trac\web\api.py", line 339, in send_error
    'text/html')
  File "C:\Python25\Lib\site-packages\trac\web\chrome.py", line 708, in render_template
    if not req.session or not int(req.session.get('accesskeys', 0)):
  File "C:\Python25\Lib\site-packages\trac\web\api.py", line 168, in __getattr__
    value = self.callbacks[name](self)
  File "C:\Python25\Lib\site-packages\trac\web\main.py", line 257, in _get_session
    return Session(self.env, req)
  File "C:\Python25\Lib\site-packages\trac\web\session.py", line 141, in __init__
    self.promote_session(sid)
  File "C:\Python25\Lib\site-packages\trac\web\session.py", line 219, in promote_session
    (self.req.authname, sid))
  File "C:\Python25\Lib\site-packages\trac\db\util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "C:\Python25\Lib\site-packages\trac\db\sqlite_backend.py", line 58, in execute
    args or [])
  File "C:\Python25\Lib\site-packages\trac\db\sqlite_backend.py", line 50, in _rollback_on_error
    return function(self, *args, **kwargs)
IntegrityError: columns sid, authenticated, name are not unique

Attachments (0)

Change History (3)

comment:1 by anonymous, 11 years ago

What version of Trac are you using specifically? This is likely a duplicate of #3563.

comment:2 by Christian Boos, 11 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Right, duplicate of #3563, shouldn't happen anymore with 0.11.1, please upgrade.

comment:3 by Christian Boos, 9 years ago

Rather a duplicate of #7094.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.