Edgewall Software
Modify

Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#7094 closed defect (fixed)

Traceback: "IntegrityError: columns sid, authenticated are not unique"

Reported by: peter.arrenbrecht@… Owned by: Remy Blank
Priority: normal Milestone: 0.12.3
Component: general Version: 0.10.3
Severity: major Keywords:
Cc: Thijs Triemstra Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

I tried to log on while viewing a ticket I wanted to close. Then I got the following:

Traceback (most recent call last):
  File "/var/lib/python-support/python2.4/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.4/trac/web/main.py", line 184, in dispatch
    req.session = Session(self.env, req)
  File "/var/lib/python-support/python2.4/trac/web/session.py", line 52, in __init__
    self.promote_session(sid)
  File "/var/lib/python-support/python2.4/trac/web/session.py", line 152, in promote_session
    (self.req.authname, int(time.time())))
  File "/var/lib/python-support/python2.4/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/var/lib/python-support/python2.4/trac/db/sqlite_backend.py", line 56, in execute
    args or [])
  File "/var/lib/python-support/python2.4/trac/db/sqlite_backend.py", line 48, in _rollback_on_error
    return function(self, *args, **kwargs)
IntegrityError: columns sid, authenticated are not unique

Attachments (0)

Change History (7)

comment:1 by Emmanuel Blot, 11 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate, search the Trac DB before submitting a new ticket.

comment:2 by Christian Boos, 9 years ago

Milestone: 0.12.3
Resolution: duplicate
Status: closedreopened

This backtrace looks similar to the ones previously reported in #6569 and #6175. However those tickets were closed as an "installation issue", which is not really a satisfying resolution for an internal error without a clearly understood cause.

A similar issue was reported today for a Trac 0.12.1 instance, in ticket:3563#comment:13.

I remember having written something about a race condition in promote_session, but I can't find that information right now.

Also, as this is an "old" problem and not a regression, let's not delay 0.12.2 because of that.

comment:3 by Carl Fürstenberg <carl@…>, 9 years ago

I assume as 0.12.2 is released, someone could look into this problem now? If possible, we can pay for you to look into this issue.

comment:4 by Thijs Triemstra, 8 years ago

Cc: Thijs Triemstra added

comment:5 by Remy Blank, 8 years ago

Owner: changed from Jonas Borgström to Christian Boos
Status: reopenednew

comment:6 by Remy Blank, 8 years ago

Resolution: fixed
Status: newclosed

The only race condition I can see in promote_session() is if two concurrent processes interfere between the initial SELECT and the INSERT INTO of the else: clause. I have added the same workaround as for #3563 in [10825].

comment:7 by Remy Blank, 8 years ago

Owner: changed from Christian Boos to Remy Blank

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Remy Blank.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.