Edgewall Software
Modify

Opened 18 years ago

Closed 16 years ago

Last modified 10 years ago

#747 closed defect (worksforme)

source links doesn't handle space anymore

Reported by: micke@… Owned by: daniel
Priority: high Milestone:
Component: wiki system Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

In 0.6 at least it was possible to have a source:Foo%20Bar link when the fdirectory was named "Foo Bar". Trunk doesn't seem to like that very much.

Attachments (1)

Errors reported in OppTracker.doc (24.0 KB ) - added by anonymous 16 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 by daniel, 18 years ago

Milestone: 0.8

comment:2 by Jonas Borgström, 18 years ago

Status: newassigned

comment:3 by Jonas Borgström, 18 years ago

Owner: changed from Jonas Borgström to daniel
Status: assignednew

comment:4 by daniel, 18 years ago

Milestone: 0.80.9

comment:5 by wallylynn@…, 18 years ago

I noticed the same thing when I updated my 0.7.1 to 0.8. The manually encoded spaces in my links are reencoded from %20 to %2520 (aka. the "%" gets encoded). After reviewing the timeline, I found what I think to be the cause: ticket #690 and corresponding changeset [864]

I undid the change on my local install and the %20 works now. Thank you, version control! Obviously, I need to be wary of other characters in my filenames now.

Since Trac uses the space as a delimiter, I will try to make "%20" a special case. I'll try to decode it back to a space and let the python library do it's work to reencode it.

comment:6 by kevin@…, 17 years ago

Here's a reasonable solution. The problem is that you can't have TracLinks including raw spaces, because the space ends the link. So you have to encode it as %20. But then that gets re-encoded into %2520 when the URL itself is url-encoded. However, any other character is valid in a link so you don't have to encode those.

So basically, the easiest solution is to do a simple string substitution on the link, turning "%20" into " ", before running it through the url encoding. You should be able to stick this right before each new line from [864] and be done.

comment:7 by Mark Rowe, 17 years ago

Resolution: fixed
Status: newclosed

Resolved in [1398]. Thanks for the report and feedback.

by anonymous, 16 years ago

comment:8 by SoloTurn, 16 years ago

Milestone: 0.90.10
Priority: normalhigh

it does not seem to work with urls like program files

comment:9 by anonymous, 16 years ago

Resolution: fixed
Status: closedreopened

comment:10 by Christian Boos, 16 years ago

Resolution: worksforme
Status: reopenedclosed

That behavior was changed on purpose in r3143. See the corresponding commit log message for further details.

comment:11 by Christian Boos, 16 years ago

Milestone: 0.100.9

comment:12 by Christian Boos, 10 years ago

Milestone: 0.9

(clearing report:35)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain daniel.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from daniel to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.