Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#746 closed defect (wontfix)

DOCTYPE and Firebird collide

Reported by: ojilles@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.7.1
Severity: normal Keywords: firebird doctype
Cc: ojilles@… Branch:
Release Notes:
API Changes:

Description

I'm using firebird 0.7. As long as header.cs contains this:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
        "http://www.w3.org/TR/2000/REC-xhtml1-20000126/DTD/xhtml1-strict.dtd">

The CSS files are not getting loaded. Whereas if I load exactly the same URL in IE (v. 6.0.2600). If I just remove the doctype declaration everything just works correctly (not that we're complying with any spec then…).

On a similar note, if I try to load http://projects.edgewall.com/trac/download/ in Firbird it won't load.

Attachments (0)

Change History (3)

comment:1 by anonymous, 15 years ago

Cc: ojilles@… added

comment:2 by Matthew Good <matt-good.net>, 15 years ago

Resolution: wontfix
Status: newclosed

I'm closing this bug since it's not a Trac bug, it's a Firebird one and Firebird 0.7 is outdated. Firebird is now named Firefox and is up to version 0.9.3 at this time. Please download an up-to-date version of Firefox.

In the future if you find bugs along these lines where a bug in other software causes problems with Trac, it is best to file the bug report for the other software, not for Trac. In some cases it may be necessary for Trac to provide workarounds for these types of bugs, but it's still best to fix the root cause of the bug.

comment:3 by ojilles@…, 15 years ago

Matt,

Thanks for the explanation. I didn't think that Firebird was so outdated that those doctype declarions would break rendering the pages. Anyway, thanks for the explanation, I'll try to upgrade.

Jilles

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.