Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#7288 closed defect (duplicate)

[PATCH] Log level is too high for missing optional dependencies

Reported by: Dave Gynn <dgynn@…> Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.11-stable
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

The load_eggs function in loader.py logs WARNING messages when optional dependencies are not found. This means that a correctly configured installation will almost always be logging warning messages. For example, Trac optionally requires SilverCity and will always log warning messages if it is not installed.

These messages are useful, but should be at the debug log level. The attached patch lowers the log level.

Attachments (1)

loader-missing-dep-warning.diff (581 bytes ) - added by Dave Gynn <dgynn@…> 12 years ago.

Download all attachments as: .zip

Change History (2)

by Dave Gynn <dgynn@…>, 12 years ago

comment:1 by Christian Boos, 12 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #5595.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.