Edgewall Software
Modify

Opened 12 years ago

Closed 11 years ago

#7287 closed defect (duplicate)

'ascii' codec can't decode byte 0xe5 in position 0: ordinal not in range(128)

Reported by: patria@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: i18n Version: 0.11.2.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

Oops… Trac detected an internal error:

If you think this really should work and you can reproduce it, you should consider reporting this problem to the Trac team.

Go to http://trac.edgewall.org/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the Python traceback found below.

TracGuide — The Trac User and Administration Guide Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.4/site-packages/TracAccountManager-0.1.2.egg/acct_mgr/web_ui.py", line 117, in process_request
  File "/usr/local/lib/python2.4/site-packages/TracAccountManager-0.1.2.egg/acct_mgr/web_ui.py", line 124, in _do_create
  File "/usr/local/lib/python2.4/site-packages/TracAccountManager-0.1.2.egg/acct_mgr/api.py", line 85, in has_user
  File "/usr/local/lib/python2.4/site-packages/TracAccountManager-0.1.2.egg/acct_mgr/htfile.py", line 41, in has_user
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe5 in position 0: ordinal not in range(128)

Attachments (1)

view.JPG (185.6 KB ) - added by patria@… 12 years ago.
'ascii' codec can't decode byte 0xe5 in position 0: ordinal not in range(128)

Download all attachments as: .zip

Change History (6)

by patria@…, 12 years ago

Attachment: view.JPG added

'ascii' codec can't decode byte 0xe5 in position 0: ordinal not in range(128)

comment:1 by Noah Kantrowitz, 12 years ago

Description: modified (diff)

Are you trying to register a username that is not plain ASCII?

comment:2 by osimons, 12 years ago

Keywords: needinfo added

In a way this looks like an 'invalid' ticket as it seems to be directly related to th:AccountManagerPlugin, and the ticket should be registered there.

However, depending on the actual circumstances, it may also be a 'duplicate' of #6318 as there seems to be some issues with non-ascii logins.

To repeat Noah's question: Did the login contain non-ascii characters?

comment:3 by Christian Boos, 12 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Eventually related to #6318 or #7325, but without the requested feedback it's hard to tell.

comment:4 by zeljko_t@…, 11 years ago

Component: generali18n
Keywords: needinfo removed
Resolution: duplicate
Severity: criticalnormal
Status: closedreopened
Version: 0.10.40.11.2.1

I can confirm that this happens if UTF-8 is used in htdigest file.

Additional problem: is UTF-8 in htdigest supported by Apache in the first place? I could not find any information about that.

comment:5 by Christian Boos, 11 years ago

Resolution: duplicate
Status: reopenedclosed

Yes, so that's definitely a duplicate of #6318, i.e. non-ascii login names are simply not supported yet.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.