Edgewall Software
Modify

Opened 13 years ago

Closed 12 years ago

#5595 closed defect (fixed)

[PATCH] Errors in the log file for optional components

Reported by: Dave Abrahams <dave@…> Owned by: Jonas Borgström
Priority: normal Milestone: 0.11
Component: general Version: devel
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Trac's log files show errors because I don't have Textile or SilverCity installed. Textile support, unlike docutils support, is not even documented as being supported AFAIK. SilverCity is only used for backward compatibility with old plugins. Showing ERROR in the log for these is too alarming.

Attachments (1)

log_spam_fix.patch (579 bytes ) - added by trac.jesseluna@… 13 years ago.
Logs to DEBUG rather than ERROR.

Download all attachments as: .zip

Change History (11)

comment:1 by Christian Boos, 13 years ago

Keywords: mimeview added

Are you sure you're having this issue with trunk? Seems like it's an 0.10 issue which is already fixed…

in reply to:  1 comment:2 by Dave Abrahams <dave@…>, 13 years ago

Replying to cboos:

Are you sure you're having this issue with trunk?

Oh, yes. Very, very, very sure.

comment:3 by Christian Boos, 13 years ago

Ok, I checked a bit further: actually something must be wrong with your installation, as both Textile and SilverCity are now "extra" dependencies and the corresponding mimeview module should only be enabled if those dependencies are satisfied. Check source:trunk/setup.py.

comment:4 by Dave Abrahams <dave@…>, 13 years ago

Yes, that's what I'm using on two separate installations on different machines. And yet:

2007-06-27 07:33:24,505 Trac[__init__] ERROR: Skipping "trac.mimeview.txtl = trac.mimeview.txtl [textile]": ("textile>=2.0" not found)
...
2007-06-27 07:33:24,533 Trac[__init__] ERROR: Skipping "trac.mimeview.silvercity = trac.mimeview.silvercity [silvercity]": ("SilverCity>=0.9.4" not found)

These don't seem like they should be errors to me.

comment:5 by jfernandez@…, 13 years ago

I'm working with Trac 0.11dev-r5762 installed directly from the trunk using easy_install http://svn.edgewall.com/repos/trac/trunk, and my trac.log has the same "errors":

2007-06-27 11:44:15,286 Trac[loader] ERROR: Skipping "trac.mimeview.rst = trac.mimeview.rst [rest]": ("docutils≥0.3" not found)

2007-06-27 11:44:15,305 Trac[loader] ERROR: Skipping "trac.mimeview.silvercity = trac.mimeview.silvercity [silvercity]": ("SilverCity≥0.9.4" not found)

2007-06-27 11:44:15,752 Trac[loader] ERROR: Skipping "trac.mimeview.txtl = trac.mimeview.txtl [textile]": ("textile≥2.0" not found)

So, it seems like the problem is not with setup.py

by trac.jesseluna@…, 13 years ago

Attachment: log_spam_fix.patch added

Logs to DEBUG rather than ERROR.

comment:6 by anonymous, 13 years ago

Keywords: mimeview removed
Milestone: 0.11.10.11
Summary: Errors in the log file for optional components[PATCH] Errors in the log file for optional components

It's a trivial change, probably an oversight in the setuptools implementation. See PkgResources exceptions.

in reply to:  6 comment:7 by Emmanuel Blot, 13 years ago

Replying to anonymous:

It's a trivial change, probably an oversight in the setuptools implementation. See PkgResources exceptions.

Please do not change the ticket summary when a patch is added.

comment:8 by Christian Boos, 13 years ago

Resolution: fixed
Severity: normalminor
Status: newclosed

I think this deserves at least a warning, as we can't really know if the dependency is missing on purpose or not.

Fixed in [6121].

comment:9 by Christian Boos, 12 years ago

Resolution: fixed
Status: closedreopened

Ok, #7288 asked again for getting DEBUG level instead of WARNING, so I think we're going to lower it nevertheless.

comment:10 by Christian Boos, 12 years ago

Resolution: fixed
Status: reopenedclosed

Done so in [7182].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.