Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 7 years ago

#7232 closed defect (fixed)

Workflow, action title disabled (grayed out)

Reported by: kirean@… Owned by: Eli Carter
Priority: normal Milestone: 0.11
Component: ticket system Version: 0.11b2
Severity: normal Keywords: workflow
Cc: Branch:
Release Notes:
API Changes:

Description

I was working on some custom workflow actions when one of my action titles ended up gray.

I've attached an example on how to recreate the issue.

Note: no entry should be made in [ticket-workflow] section for this plugin example. Just remember to add the TestveActionController to the available workflows.

By changing the id to something else the the action name the problem is solved.

control.append(tag([' ', tag.input(type='text', id='testing_%s' % ticket['status'],

Attachments (1)

gray_title.txt (3.2 KB ) - added by kirean@… 12 years ago.

Download all attachments as: .zip

Change History (5)

by kirean@…, 12 years ago

Attachment: gray_title.txt added

comment:1 by Eli Carter, 12 years ago

Status: newassigned

The name of the action is used as the id for the radio button. Any id used within the control needs to be made unique, such as by using the action value as part of any id.

For example:

    def render_ticket_action_control(self, req, ticket, action):
        control = tag([' ', tag.input(type='text', id=action+'_testing',
                                           name='testing', value=('Testing'))])
...

Looks like I'd better document this.

comment:2 by Eli Carter, 12 years ago

Further, this means that the names of actions have to be unique as ids in the ticket.html… and that is less than desirable. So, I'm changing it to prefix each of those ids with action_. So the ids used as part of a ticket action control should look like "action_%s_whatever" % action.

comment:3 by Eli Carter, 12 years ago

Resolution: fixed
Status: assignedclosed

Fixed. Also, documentation added to ITicketActionController.render_ticket_action_control().

comment:4 by Christian Boos, 7 years ago

Milestone: 0.11

(fixing {36})

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Eli Carter.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Eli Carter to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.