Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#7179 closed defect (fixed)

report grouping broken

Reported by: Christian Boos Owned by: Christian Boos
Priority: high Milestone: 0.11
Component: report system Version: devel
Severity: normal Keywords:
Cc: kamil@… Branch:
Release Notes:
API Changes:

Description

It seems that the __group__ feature of the TracReports doesn't work anymore, likely due to r6842.

This is visible on t.e.o with {21} (all results fit in a page, so the paging support is not in cause).

Attachments (1)

report_grouping.patch (1.3 KB ) - added by jasminlapalme@… 11 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 by Christian Boos, 11 years ago

Owner: changed from Matthew Good to Christian Boos

Shouldn't delay rc1, but needs to be fixed before 0.11.

comment:2 by jasminlapalme@…, 11 years ago

I fix the problem with this patch (report_grouping.patch). In the SQL query no ordering was made since it was using the column indexes to sort. I change it to use the column names.

by jasminlapalme@…, 11 years ago

Attachment: report_grouping.patch added

comment:3 by Christian Boos, 11 years ago

Status: newassigned

Thanks for the patch.

But I'm afraid it's not enough to completely fix the sorting for groups: if we take sort col to be __group__, then we have no way to sort on the value as opposed to the name, like done in r6842. We probably need an extra __groupvalue__ special name for this.

comment:4 by Christian Boos, 11 years ago

Priority: normalhigh

#7224 was closed as duplicate of this ticket.

comment:5 by Kamil Kisiel <kamil@…>, 11 years ago

Cc: kamil@… added

The fact that the report's SQL query is wrapped by another SELECT query (presumably for pagination support) is also messing up ordering in PostgreSQL. With the patch, if I use __group__ in my report, the order of the tickets returned not preserved within each group.

eg: If they were originally sorted by ticket #, the sort order will be pretty much random. Try the following query to see this effect:

SELECT milestone AS __group__,
   id AS ticket, summary, component, version, t.type AS type, severity, 
   owner, status,
   time AS created,
   changetime AS _changetime, description AS _description,
   reporter AS _reporter
  FROM ticket t, enum p
  WHERE status <> 'closed' 
AND p.name = t.priority AND p.type = 'priority'
  ORDER BY ticket

comment:6 by nate@…, 11 years ago

I can confirm this bug exists in 0.11rc1. I just upgraded my environment to the RC and noticed immediately that my report groupings are broken.

comment:7 by Christian Boos, 11 years ago

Resolution: fixed
Status: assignedclosed

Fix verified and committed as [7130], many thanks Jasmin!

comment:8 by azaiats@…, 11 years ago

Resolution: fixed
Status: closedreopened

This fix 'doesn't fix' the error occurring with Timing and Estimating Plugin

http://www.trac-hacks.org/wiki/TimingAndEstimationPlugin

The reports now are totally 'blank'.

comment:9 by Christian Boos, 11 years ago

Resolution: fixed
Status: reopenedclosed

Sorry, that's not the place where that plugin is maintained, and you don't even say what is that error with this plugin.

You have to report the error to the plugin maintainer, and if he thinks Trac is doing something wrong, then he'll be the more appropriate person to (re)open a bug in this Trac.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.