Edgewall Software
Modify

Opened 12 years ago

Closed 4 years ago

#7015 closed enhancement (duplicate)

Provide interface to fill custom select-boxes

Reported by: Markus.Staab Owned by:
Priority: normal Milestone:
Component: ticket system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

would be nice to have a interface which can provide data for the selectboxes you can find in the properties fieldset of a ticket.

we have the problem that our software has a lot of plugins which are all described in the trac-wiki and the ticket system is used for managing the bugs etc.

The component select-box is very often not uptodate because someone added a new plugin and this plugin wasn't added to the component list yet.. so the problem is, that nobody can report bugs/feature request which are related to the new plugin..

Attachments (0)

Change History (7)

comment:1 by Christian Boos, 12 years ago

Milestone: 0.10.5

The ideal solution for your situation would be to have components as 1st class resources. Therefore each time you would create and document a new component, it will become available in the drop-down (see #5211).

One interim solution is to give more people the possibility to update the list of components (TICKET_ADMIN + WebAdmin plugin, as you're using 0.10).

The alternative of providing an input text field to all users is a bit risky, as you'll likely end up with duplicate or invalid components.

comment:2 by Remy Blank, 11 years ago

Milestone: 2.0

Components as first-class resources is not on the radar yet.

comment:3 by Christian Boos, 9 years ago

Milestone: 2.0unscheduled

Milestone 2.0 deleted

comment:4 by Christian Boos, 9 years ago

Milestone: triagingunscheduled

comment:5 by Ryan J Ollos, 4 years ago

Owner: Christian Boos removed

in reply to:  2 comment:6 by anonymous, 4 years ago

Replying to rblank:

Components as first-class resources is not on the radar yet.

Please try harder

comment:7 by Ryan J Ollos, 4 years ago

Keywords: ticket component custom interface removed
Milestone: unscheduled
Resolution: duplicate
Status: newclosed

We have WebAdmin integrated into Trac and TracFineGrainedPermissions can be used to grant TICKET_ADMIN for /admin/ticket/components if you wish to allow a broader audience to edit the available components (since milestone:1.0.2, see #11069).

In addition to #5211, #1233 will focus on making Components first-class objects of the ticket system.

Closing as a duplicate of #11069.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.