Edgewall Software
Modify

Opened 13 years ago

Last modified 14 months ago

#1233 new enhancement

Descriptions of Components

Reported by: Matthew Harrison Owned by:
Priority: normal Milestone: next-dev-1.3.x
Component: ticket system Version: 0.8
Severity: major Keywords: component version
Cc: leho@…, dale.miller@…, tony@…, notify_craig@…, whatrevolution@…
Release Notes:
API Changes:

Description

One annoying problem we have with our existing bug-tracking system is that users often don't know what component to select for a ticket. They often end up choosing an inappropriate one.

One could argue that better component names would minimise this, but I've often found users to be endlessly creative in their quest to misunderstand the (seemingly) obvious ;-) A nice feature of bugzilla is that the component selector label is a link to a page listing the components for the project, along with owner and description. (If you prefer the link could be a separate item, like a '?' icon.)

(Currently I'm conducting a trial of trac, and I quite like it!)

Attachments (0)

Change History (41)

comment:1 Changed 13 years ago by Christian Boos

Owner: changed from Jonas Borgström to Christian Boos
Status: newassigned

A component could be a specific Trac object. Clicking on a component would go to its page, which would contain a wiki description.

See other suggested use for a Component object in TracMultipleProjects/SingleEnvironment#UsingComponentobjects.

comment:2 Changed 13 years ago by Christopher Lenz

Components now have a "description" column in the table. It's not being used yet, but it will be in the future for this purpose.

comment:3 Changed 13 years ago by Christian Boos

Status: assignednew

(changing the status, as I've not actually started to work on that yet)

comment:4 Changed 13 years ago by Christian Boos

Keywords: object added

comment:5 Changed 12 years ago by Christian Boos

Keywords: tracobject added; object removed

comment:6 Changed 12 years ago by Christian Boos

Milestone: 1.0

Can be done in GenericTrac, as a second step, in order to validate the steps needed to create of a new kind of resource.

comment:7 Changed 11 years ago by Christian Boos

Milestone: 1.00.12

#5860 closed as duplicate (was asking to actually make use of the component description that one can already set in the component admin panel).

comment:8 in reply to:  2 Changed 10 years ago by Christian Boos

Keywords: component added; tracobject removed

Replying to cmlenz:

Components now have a "description" column in the table. It's not being used yet, but it will be in the future for this purpose.

Re-focusing this ticket for this goal. For the idea of having components as first-class object in the Trac system, see #3911. #7411 closed as duplicate of this ticket.

comment:9 Changed 9 years ago by Remy Blank

Milestone: 0.130.12
Owner: changed from Christian Boos to Remy Blank

This feature sounds useful. How about the following plan:

  • Add a [[TicketComponents]] macro that expands to the list of components, with their descriptions and owners (similar to [[TracIni]] as a table, for example).
  • Create a default page TicketComponents that includes the macro and some explanations.
  • Link to the TicketComponents page from the "Component" label in the ticket properties, as suggested by the reporter.

comment:10 Changed 9 years ago by Remy Blank

The same functionality was requested on trac-users, but for the version field. In principle, nothing would stop us from adding a description to all enumerated field types, and to have a TicketEnumFields page with one table for each field containing the values and descriptions.

I'll start with the fields that have a description.

comment:11 in reply to:  10 ; Changed 9 years ago by jhammel@…

Replying to rblank:

The same functionality was requested on trac-users, but for the version field. In principle, nothing would stop us from adding a description to all enumerated field types, and to have a TicketEnumFields page with one table for each field containing the values and descriptions.

I'll start with the fields that have a description.

In general, it would be nice to have wiki macros for the descriptions of fields with descriptions. They could then be used in the ticket form and where ever else the information is desired.

comment:12 in reply to:  11 Changed 9 years ago by Remy Blank

Replying to jhammel@…:

In general, it would be nice to have wiki macros for the descriptions of fields with descriptions. They could then be used in the ticket form and where ever else the information is desired.

Do you mean a macro that takes a field name and value, and expands to the description of the field value? How would you use that in the ticket form?

comment:13 Changed 9 years ago by Remy Blank

Milestone: 0.120.12.1

Doesn't block 0.12, re-targeting.

comment:14 Changed 9 years ago by Emil Bleaker <emil_bleaker@…>

Type: defectenhancement

This sounds more like an enhancement than a defect.

comment:15 in reply to:  10 ; Changed 9 years ago by Ryan Ollos <ryano@…>

Replying to Matthew Harrison:

A nice feature of bugzilla is that the component selector label is a link to a page listing the components for the project, along with owner and description. (If you prefer the link could be a separate item, like a '?' icon.)

Replying to rblank:

This feature sounds useful. How about the following plan:

  • Add a [[TicketComponents]] macro that expands to the list of components, with their descriptions and owners (similar to [[TracIni]] as a table, for example).
  • Create a default page TicketComponents that includes the macro and some explanations.
  • Link to the TicketComponents page from the "Component" label in the ticket properties, as suggested by the reporter.

This could mostly be hacked together with the current system, which is sort of what I have done.

I've used the th:WikiTableMacro to show a list of components on a page, along with their descriptions.

{{{
#!SQLTable
SELECT name, description FROM component ORDER BY name
}}}

However, I agree that the macro would be a nice feature.

I've changed the ticket template to transform the Component: text into a link to a wiki page.

Another nice feature would be to have a tooltip showing the description when there is a mouseover on a particular component in the drop down list.

Replying to rblank:

The same functionality was requested on trac-users, but for the version field. In principle, nothing would stop us from adding a description to all enumerated field types, and to have a TicketEnumFields page with one table for each field containing the values and descriptions.

If this could be extended to custom fields as well, that would be ideal. I have a wiki page that explains all of the fields of the tickets, including a number of custom fields. I use the SQL query as shown above for items such as Component, but I have had to manually create and update the wiki page for custom fields.

comment:16 Changed 8 years ago by Christian Boos

Milestone: next-minor-0.12.xnext-major-0.1X

Too big enhancement for a minor version.

comment:17 Changed 8 years ago by Christian Boos

Owner: Remy Blank deleted
Severity: normalmajor

comment:18 Changed 8 years ago by Remy Blank

Owner: set to Remy Blank

Hey! I'm still interested!

comment:19 Changed 8 years ago by Christian Boos

Well, yes, but me too ;-)

I reset the owner as we're having two different approaches here (comment: 6 vs comment:9), and no immediate progress in either direction.

comment:20 Changed 8 years ago by lkraav <leho@…>

btw, th:ComponentsProcessorMacro exists. looking at the this ticket's description, i think it could serve as a hold-me-over in many cases.

comment:21 Changed 8 years ago by lkraav <leho@…>

Cc: leho@… added

comment:22 Changed 8 years ago by dale.miller@…

Cc: dale.miller@… added

comment:23 Changed 5 years ago by tony@…

Cc: tony@… added

comment:24 in reply to:  15 Changed 5 years ago by Ryan J Ollos <ryan.j.ollos@…>

Cc: ryan.j.ollos@… added

Replying to Ryan Ollos <ryano@…>:

Another nice feature would be to have a tooltip showing the description when there is a mouseover on a particular component in the drop down list.

This has been implemented by matobaa in the FieldTooltipPlugin.

I'd be interested in implementing the plan in comment:9 for Components, Versions and all of the ticket enums. I've also previously thought it would be valuable to have a Description field for the ticket enums, so I'd also be interested in implementing that feature as well (comment:10).

Would there be interesting in integrating those features into the core if I developed them on a branch, or is the focus entirely on the long-term vision of GenericTrac?

comment:25 Changed 5 years ago by Christian Boos

It would be nice as such. For this kind of feature, changing the DB representation would have little impact, so no need to delay.

The current link on the component field of tickets goes to a custom query for that component, it would be nice to somehow keep that possibility with the proposed macro, even indirectly (i.e. the macro could generate that link into an extra column open tickets).

OTOH, having a full blown component "page", looking much like the milestone page, but with side-by-side edit capabilities like a wiki page, keeping track of the history of changes, etc. is of course what GenericTrac is about ;-)

comment:26 Changed 5 years ago by Ryan J Ollos <ryan.j.ollos@…>

Okay, cool. I have a few other in-progress patches to finish up first, but I'll add this ticket to the queue, and hope to provide a patch in the coming weeks.

comment:27 Changed 5 years ago by notify_craig@…

Cc: notify_craig@… added

comment:28 Changed 5 years ago by Ryan J Ollos

Cc: ryan.j.ollos@… removed
Milestone: next-major-releasesnext-dev-1.1.x
Owner: changed from Remy Blank to Ryan J Ollos
Status: newassigned

comment:29 Changed 5 years ago by whatrevolution@…

Cc: whatrevolution@… added

comment:30 Changed 5 years ago by Ryan J Ollos

Milestone: next-dev-1.1.x1.1.3

comment:31 in reply to:  10 Changed 4 years ago by Ryan J Ollos

Replying to rblank:

The same functionality was requested on trac-users, but for the version field. In principle, nothing would stop us from adding a description to all enumerated field types,

#11649 is a ticket for adding a description field to each ticket system enum.

comment:32 in reply to:  9 Changed 4 years ago by Ryan J Ollos

Replying to rblank:

  • Add a [[TicketComponents]] macro that expands to the list of components, with their descriptions and owners (similar to [[TracIni]] as a table, for example).

Since this ticket will be a large amount of work I created a separate ticket for adding the macro: #11702.

comment:33 Changed 4 years ago by Ryan J Ollos

Milestone: 1.1.3next-dev-1.1.x

It's probably more realistic to target this in milestone:1.1.4 or later.

comment:34 Changed 3 years ago by Ryan J Ollos

Milestone: next-dev-1.1.x1.1.5

comment:35 Changed 3 years ago by Ryan J Ollos

#5211 is a subtask in implementing first-class Components.

Last edited 3 years ago by Ryan J Ollos (previous) (diff)

comment:36 Changed 3 years ago by Ryan J Ollos

Milestone: 1.1.51.2

comment:37 Changed 3 years ago by Ryan J Ollos

Milestone: 1.21.1.6

Milestone renamed

comment:38 Changed 3 years ago by Ryan J Ollos

Milestone: 1.1.6next-dev-1.1.x
Owner: Ryan J Ollos deleted
Status: assignednew

comment:39 Changed 3 years ago by Ryan J Ollos

#4827 requests that addition of COMPONENT_CREATE, COMPONENT_MODIFY, etc …

comment:40 Changed 3 years ago by Ryan J Ollos

Milestone: next-dev-1.1.xnext-dev-1.3.x

Narrowing focus for milestone:1.2. Please move ticket to milestone:1.2 if you intend to fix it.

comment:41 Changed 14 months ago by Ryan J Ollos

Keywords: version added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned.
as The resolution will be set.
The owner will be changed from (none) to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.