Edgewall Software
Modify

Opened 15 years ago

Closed 12 years ago

Last modified 9 years ago

#6143 closed defect (cantfix)

Error on browsing Plone collective

Reported by: enzo.cesanelli@… Owned by: Christian Boos
Priority: normal Milestone:
Component: version control Version: 0.10.4
Severity: normal Keywords: svnauthz, needinfo, authzsourcepolicy
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

If you try to browse the collective sorted by reversed date order on:
http://dev.plone.org/collective/browser/?order=date&desc=1

This error is generated:

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/web_ui/browser.py", line 143, in process_request
    self._render_directory(req, repos, node, rev)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/web_ui/browser.py", line 189, in _render_directory
    info = sorted(info, key=browse_order, reverse=desc)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/web_ui/browser.py", line 188, in browse_order
    return a['is_dir'] and dir_order or 0, file_order(a)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/web_ui/browser.py", line 176, in file_order
    return changes[a['rev']]['date_seconds']
KeyError: 'date_seconds' 

Attachments (0)

Change History (10)

comment:1 by Christian Boos, 15 years ago

Component: generalversion control
Description: modified (diff)
Milestone: not applicable0.10.5
Owner: changed from Jonas Borgström to Christian Boos

Another symptom of the changeset info being used but not provided (probably due to a permission check).

Note: see get_changes in trac/versioncontrol/web_ui/util.py.

comment:2 by Christian Boos, 15 years ago

Milestone: 0.10.5
Resolution: wontfix
Status: newclosed

Actually this is problem that can be located to http://dev.plone.org/collective/browser/root/EasyShop/branches/diefenbach-3.0 and the fact that there's a missing changeset [51954].

Probably consecutive to another occurrence of the issue #5440.

comment:3 by enzo.cesanelli@…, 15 years ago

I've noted the issue to Kai, the mantainer of EasyShop. He fixed it and now the Plone Collective by date works again!

in reply to:  3 comment:4 by Christian Boos, 15 years ago

Replying to enzo.cesanelli@gmail.com:

I've noted the issue to Kai, the mantainer of EasyShop. He fixed it …

I'm curious how. Did something had to be done at the SVN level or was it only a matter of doing the resync (full or for that revision only)?

comment:5 by enzo.cesanelli@…, 14 years ago

Resolution: wontfix
Status: closedreopened

Same issue, again… :( Does not exist any way to prevent it? Thanks,

Enzo

comment:6 by Christian Boos, 14 years ago

This time it's PloneServicesCenter/trunk/i18n and r74514 which didn't "sync". As usual, no idea why…

Is that changeset "normal" at the svn level? i.e. does a svn log --xml --verbose -r74514 work? (what's the svn URL by the way?)

comment:7 by Christian Boos, 14 years ago

Keywords: svnauthz added
Milestone: 0.11.4
Priority: highnormal

Looks like some changesets are available through the command line, some others not. Those which create problems in Trac are not, but some which are not available publicly are nevertheless reachable in Trac. Is there some svn_authz issue going on here?

comment:8 by Remy Blank, 13 years ago

Keywords: needinfo added

comment:9 by Christian Boos, 12 years ago

Milestone: next-minor-0.12.x
Resolution: cantfix
Status: reopenedclosed

No feedback, closing again.

comment:10 by Ryan J Ollos, 9 years ago

Keywords: authzsourcepolicy added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.