Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#5913 closed enhancement (duplicate)

improvements to ticket navigation

Reported by: jeff.webb@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version:
Severity: normal Keywords: ticket navigation breadcrumb
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

sorry if this has been addressed but searching through the system revealed no obvious open defects/enhancements.

I would love to see an improved navigation system built into the ticket system. I have two specific (and not necessarily mutually exclusive) thoughts in mind:

  1. from a report list the ability to navigate prev/next through the list.
  2. a breadcrumb on the page (top & bottom) that will link you back to the report list.

The issue is that it takes too many clicks to navigate through a list of defects that you might be processing. Example:

  1. click "view tickets"
  2. choose a report
  3. click on the first defect
  4. edit the defect

at this point to get to the 2nd defect in the report list you have to repeat steps 1-3 but choosing the 2nd defect or you have to use the browser back button.

At the very least having a breadcrumb would allow you easy access back to the report screen. A prev/next metaphor would be ideal.

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 13 years ago

Resolution: duplicate
Status: newclosed

… searching through the system revealed no obvious open defects/enhancements.

You should have looked for closed defects/enhancements as well ;-)

  1. is already implemented in milestone:0.11, see #2119.
  2. while not really part of a breadcrumb (see #2449 for that feature request), the usual Back in the Prev | Back | Next sequence of links leads you back to the report, when you're coming from a report.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.