Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#5587 closed defect (duplicate)

Internal error while browsing source of PHP file

Reported by: marcel Owned by: Christian Boos
Priority: normal Milestone:
Component: version control/browser Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

If I have a PHP file that contains

<? print '<a href="http://google.com/">honk</a>'; ?>

Trac is unable to display it in the source code browser. It gives this traceback:

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 389, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 246, in dispatch
    req.display(template, content_type or 'text/html')
  File "/usr/lib/python2.3/site-packages/trac/web/api.py", line 358, in display
    data = self.hdf.render(template, form_token)
  File "/usr/lib/python2.3/site-packages/trac/web/clearsilver.py", line 296, in render
    injector.feed(template.render())
  File "/usr/lib64/python2.3/HTMLParser.py", line 108, in feed
    self.goahead(0)
  File "/usr/lib64/python2.3/HTMLParser.py", line 150, in goahead
    k = self.parse_endtag(i)
  File "/usr/lib64/python2.3/HTMLParser.py", line 327, in parse_endtag
    self.error("bad end tag: %s" % `rawdata[i:j]`)
  File "/usr/lib64/python2.3/HTMLParser.py", line 115, in error
    raise HTMLParseError(message, self.getpos())
HTMLParseError: bad end tag: '</a">', at line 96, column 163

Attachments (0)

Change History (3)

comment:1 by marcel, 15 years ago

Is there any word on whether this is a bug or a system-specific problem?

comment:2 by sid, 15 years ago

What version of Trac are you using?

comment:3 by Christian Boos, 15 years ago

Resolution: duplicate
Status: newclosed

duplicate of #4365.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.