Edgewall Software
Modify

Opened 13 years ago

Closed 12 years ago

#4365 closed task (wontfix)

SilverCity on t.e.o needs to be updated

Reported by: Tim Hatch <trac@…> Owned by: Jonas Borgström
Priority: high Milestone:
Component: project Version: 0.10.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

For example http://trac.edgewall.org/browser/trunk/trac/mimeview/tests/api.py?rev=3025 produces a traceback. The root cause is a SilverCity autolink bug which I reported upstream mid-Nov, and I believe is now fixed in the released 0.97: see http://sourceforge.net/forum/forum.php?forum_id=637878 for release note.

I am aware that Clearsilver/SilverCity in general has a limited lifespan due to Pygments now being supported, but this issue prevents viewing source on t.e.o and is hopefully a simple fix (just upgrade the package).

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 244, in dispatch
    req.display(template, content_type or 'text/html')
  File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 358, in display
    data = self.hdf.render(template, form_token)
  File "/usr/lib/python2.4/site-packages/trac/web/clearsilver.py", line 296, in render
    injector.feed(template.render())
  File "/usr/lib/python2.4/HTMLParser.py", line 108, in feed
    self.goahead(0)
  File "/usr/lib/python2.4/HTMLParser.py", line 150, in goahead
    k = self.parse_endtag(i)
  File "/usr/lib/python2.4/HTMLParser.py", line 314, in parse_endtag
    self.error("bad end tag: %r" % (rawdata[i:j],))
  File "/usr/lib/python2.4/HTMLParser.py", line 115, in error
    raise HTMLParseError(message, self.getpos())
HTMLParseError: bad end tag: '</a">', at line 182, column 147

Attachments (0)

Change History (5)

comment:1 by Christian Boos, 13 years ago

Milestone: none
Priority: normalhigh
Type: defecttask

Symptom reported again in #4691.

comment:2 by anonymous, 12 years ago

Milestone: not applicable1.0
Priority: highhighest
Type: taskenhancement
Version: 0.10.20.9

comment:3 by Emmanuel Blot, 12 years ago

Milestone: 1.0
Priority: highesthigh
Type: enhancementtask
Version: 0.90.10.2

Reverting "anonymous'" changes.

comment:4 by anonymous, 12 years ago

Should this be 0.10.5 or is it going to become a wontfix since 0.11 moves to using Pygments?

comment:5 by Christian Boos, 12 years ago

Resolution: wontfix
Status: newclosed

wontfix is the more realistic option here ;-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.