Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#4364 closed defect (duplicate)

python setup.py install does not work with trac 0.10.x

Reported by: anonymous Owned by: Christopher Lenz
Priority: normal Milestone:
Component: admin/web Version: 0.10.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Emmanuel Blot)

svn co http://svn.edgewall.com/repos/trac/sandbox/webadmin
rettung:~/webadmin# python setup.py install
Traceback (most recent call last):
  File "setup.py", line 25, in ?
    packages=find_packages(exclude=['ez_setup', '*.tests*']),
TypeError: find_packages() got an unexpected keyword argument 'exclude'

Attachments (0)

Change History (3)

comment:1 by Emmanuel Blot, 14 years ago

Component: generalwebadmin
Description: modified (diff)
Owner: changed from Jonas Borgström to Christopher Lenz

comment:2 by Emmanuel Blot, 14 years ago

Keywords: needinfo added

It seems to be a duplicate of #3106.

Can you cross-check your setuptools version number?

comment:3 by Matthew Good, 14 years ago

Keywords: needinfo removed
Resolution: duplicate
Status: newclosed

Yeah, this is definitely a duplicate of #3106. You need to install setuptools 0.6 or later as per the plugins requirements.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.