Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5497 closed defect (fixed)

Component owner should not override assigned owner

Reported by: Emmanuel Blot Owned by: Eli Carter
Priority: normal Milestone: 0.11
Component: ticket system Version: devel
Severity: normal Keywords: workflow
Cc: Branch:
Release Notes:
API Changes:

Description

When the following actions are performed (at once) on an open ticket, using the default workflow:

  1. Change the component, and
  2. Re-assign to a new owner

the resulting ticket is assigned to the component default owner, not to the owner specified in the "Assign to" dropbox.

Attachments (1)

r5616.log.bz2 (8.5 KB ) - added by Emmanuel Blot 12 years ago.
Full log of failed tests (Linux)

Download all attachments as: .zip

Change History (15)

comment:1 by Emmanuel Blot, 12 years ago

Keywords: workflow added
Owner: changed from Jonas Borgström to Eli Carter

comment:2 by Eli Carter, 12 years ago

Status: newassigned

comment:3 by Eli Carter, 12 years ago

Milestone: 0.11

comment:4 by Eli Carter, 12 years ago

Hrm. I can't reproduce this on sandbox/testing. I've added a test case for it; look for !RegressionTestTicket5497 in sandbox/testing/trac/tests/functional.py

Can you look at that and see if I missed something?

comment:5 by ThurnerRupert, 12 years ago

here its more the other way round … if you change the component, the owner does not change at all. what should it be?

in reply to:  5 comment:6 by Eli Carter, 12 years ago

Replying to ThurnerRupert:

here its more the other way round … if you change the component, the owner does not change at all. what should it be?

That should be covered in the referenced testcase; the owner should change to the component owner, as I understand it.

comment:7 by ThurnerRupert, 12 years ago

could this go to 0.11.1?

comment:8 by Emmanuel Blot, 12 years ago

On retracile's request, here are the result of the test sessions I ran with the sandbox/testing branch

Working copy

URL: http://svn.edgewall.com/repos/trac/sandbox/testing Revision: 5916

Mac OS X

Mac OS X 10.4.9 {Genshi 0.4.1, 0.4.3, 0.4.4} x { Python 2.4, 2.5}

amazas:~/Sources/Svn/edgewall.org/trac/sandbox/testing eblot$ 
PYTHONPATH=`pwd`:~/Sources/Svn/edgewall.org/genshi/tags/0.4.1 python2.4 trac/test.py 
======================================================================
FAIL: Test for regression of http://trac.edgewall.org/ticket/5497
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/eblot/Sources/Svn/edgewall.org/trac/sandbox/testing/trac/tests/functional.py", line 823, in runTest
    tc.find(regex_owned_by('user'))
  File "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/twill-0.9b1-py2.4.egg/twill/commands.py", line 230, in find
    raise TwillAssertionError("no match to '%s'" % (what,))
TwillAssertionError: no match to '<_sre.SRE_Pattern object at 0x22a54a0>'

----------------------------------------------------------------------
Ran 710 tests in 165.138s

FAILED (failures=1)

Linux

Linux Debian/unstable 2.6.21-2-686 Genshi 0.4.3-1 Python 2.4
18 similar failures

eblot@vamazas:~/trac/testing$ 
PYTHONPATH=`pwd` python2.4 trac/test.py
======================================================================
FAIL: Set preferences for admin user
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/eblot/trac/testing/trac/tests/functional.py", line 647, in runTest
    tc.formvalue('prefs', 'name', 'System Administrator')
  File "/home/eblot/trac/testing/trac/tests/functional.py", line 146, in better_formvalue
    raise twill.errors.TwillAssertionError(*args)
TwillAssertionError: ('no matching forms!', '<!DOCTYPE html ...

See r5616.log.bz2 for the complete log

Note that although 18 tests fail, a tracd session with either a new Trac environment or the testenv888 environment generated by the test session work fine from a web browser perspective: no visible issue.

by Emmanuel Blot, 12 years ago

Attachment: r5616.log.bz2 added

Full log of failed tests (Linux)

comment:9 by ThurnerRupert, 12 years ago

Milestone: 0.110.11.1

according to eblot no visible issue, so it seems to block 0.11 unecessarily …

in reply to:  9 comment:10 by Emmanuel Blot, 12 years ago

Replying to ThurnerRupert:

according to eblot no visible issue, so it seems to block 0.11 unecessarily …

No, my comment was about the sandbox/testing tests, not about the primary issue.

comment:11 by Eli Carter, 12 years ago

Tim noticed that OS/X has tidy installed and twill uses it if available. It looks like the failures in the sandbox/testing branch were due to tidy. As of [6609], tidy is disabled and no longer causes test failures on OS/X.

At this point, I believe this bug is fixed. eblot, can you verify that?

in reply to:  11 comment:12 by Emmanuel Blot, 12 years ago

Replying to ecarter:

At this point, I believe this bug is fixed. eblot, can you verify that?

Works fine:

$> svn info .
URL: http://svn.edgewall.org/repos/trac/sandbox/testing
Revision: 6612
  • w/o twill
    $> PYTHONPATH=$PWD python2.5 trac/test.py 
    SKIP: functional tests (no twill installed)
    ...
    Ran 714 tests in 24.782s
    
    OK
    
  • w/ twill installed
    $> PYTHONPATH=$PWD python2.5 trac/test.py 
    ...Ran 755 tests in 166.582s
    
    OK
    

although since the original comments, I've upgraded from Tiger to Leopard, so Python version has been bumped to 2.5.

comment:13 by Eli Carter, 12 years ago

Resolution: fixed
Status: assignedclosed

comment:14 by Christian Boos, 12 years ago

Milestone: 0.11.10.11

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Eli Carter.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Eli Carter to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.