Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

#5410 closed defect (duplicate)

Tracd does not stay running as a daemon when executed with the --pidfile switch

Reported by: wlangford@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: web frontend/tracd Version: devel
Severity: trivial Keywords:
Cc: remy.blank@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I have a .sh script run as below:
$ su tracuser
$ sh Start.sh
The script contains: (Among other starting processes)

su -c "rm -f /home/will/Desktop/tracd && echo '55' > /home/will/Desktop/tracd && chmod 777 /home/will/Desktop/tracd"
tracd -d -p 8080 -s -r --auth=trac,/path/to/htdigest,trac /path/to/tracenv --pidfile=/home/will/Desktop/tracd

The script puts out the pid to the designated file, but when I cheeck the running processes, tracd is nowhere to be found… (ps -ax|grep "tracd") Running tracd from outside the sh script with the same switches produces the same effect, except that the pidfile is deleted almost immediately after creation.
Running tracd with either method without the --pidfile switch results in the daemon running correctly.

Attachments (0)

Change History (5)

comment:1 by anonymous, 15 years ago

Summary: Tracd does not stay running when executed from a .sh script.Tracd does not stay running as a daemon when executed with the --pidfile switch

comment:2 by Christian Boos, 15 years ago

Well, I think the —pidfile and the -r flag can't really be used together. Try without the -r flag to see if this improves the situation.

comment:3 by wlangford_AT_gmail.com, 15 years ago

Severity: normaltrivial

Ah, I see. It works perfectly now. =D…That needs to be better documented. When I was playing with it, tracd -d -r --pidfile=tracd, tracd responded that pidfile had to be an absolute path when using -s and -r. So, I figured that —pidfile and -r DID work together.

So, either —pidfile and -r need to be made to work together, or the built-in error messages need be clarified

comment:4 by Remy Blank <remy.blank@…>, 14 years ago

Cc: remy.blank@… added

This is related #7049. I have provided a patch there that disallows --auto-reload together with --daemonize, which would solve this ticket as well.

comment:5 by Christian Boos, 14 years ago

Milestone: 0.11.2
Resolution: duplicate
Status: newclosed

I think it's safe to close as duplicate of #7049.

Please reopen if I overlooked something.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.