Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#511 closed defect (fixed)

Source diff not displaying in changesets

Reported by: genesisdsi@… Owned by: Christopher Lenz
Priority: high Milestone: 0.9
Component: version control/changeset view Version: 0.7
Severity: major Keywords: diff
Cc: ken.barker@… Branch:
Release Notes:
API Changes:

Description

When I click on a ChangeSet or download diff from ChangeSet page, no diff is displayed.

  • Trac 0.7.1
  • SVN 1.0.4

on Win2K Pro

The FAQ recommends using diffutils from GNU or installing the latest SVN (1.0.4). I have the latest SVN installed. I install diffutils with no result.

I know a similar ticket has been closed with a wontfix severity, but I still need help.

Attachments (0)

Change History (16)

comment:1 by psohm@…, 15 years ago

Version: 0.7.10.7

i've the same problem on windows 2003 with trac 0.7

comment:2 by daniel, 15 years ago

Milestone: 0.8
Owner: changed from Jonas Borgström to daniel
Priority: normalhigh
Severity: normalblocker
Status: newassigned

I will look into this again, and see if there's problems with subversion 1.0.4. It works in Subversion 1.0.1 on windows. Very strange.

comment:3 by Ken Barker <ken.barker@…>, 15 years ago

Cc: ken.barker@… added

comment:4 by Jonas Borgström, 15 years ago

Keywords: win32 added

comment:5 by swillison@…, 15 years ago

I've had the same problem with Trac 0.7.1 running on Red Hat ES with Suversion 1.0.6 - see bug #725

comment:6 by anonymous, 15 years ago

I was having this problem, and based off of #330 I checked my path, and sure enough that was the problem.

After installing diffutils make sure you've added "C:\Program Files\GnuWin32\bin" (or wherever you installed it) to you System's Path environment variable (not your user's path).

It seems to be necessary to restart the computer for the path change to take effect. As suggested in #330, try using the printenv.pl script which should be included with Apache to make sure the path is set to what you think it is.

comment:7 by Ken Barker <ken.barker@…>, 15 years ago

Followed the advise in the prior comment and discovered three things:

  • I only downloaded the source for diffutils. (That will do it every time!)
  • The path is not set by the diffutils installer on Win 2K.
  • It works!!

I would close this ticket as invalid, but second item should be taken care of in someway during the installation of trac.

comment:8 by daniel, 15 years ago

Keywords: windows added; win32 removed
Milestone: 0.80.9
Severity: blockercritical

re-investigate for 0.9.

comment:9 by daniel, 15 years ago

Possibly add some configuration option.

comment:10 by daniel, 15 years ago

Milestone: 0.90.8

The python svn-bindings (svn.fs.FileDiff.get_pipe) to be exact, is the culprit.

It should be fixed.

comment:11 by Christopher Lenz, 15 years ago

Keywords: windows removed

#725 has been marked as duplicate of this ticket. It's not about Windows, so removed the windows keyword from the ticket.

comment:12 by Christopher Lenz, 15 years ago

Summary: Source diff not displaying in ChangeSet on windowsSource diff not displaying in changesets

comment:13 by Christopher Lenz, 15 years ago

Milestone: 0.80.9
Owner: changed from daniel to Christopher Lenz
Severity: criticalmajor
Status: assignednew

I think we should migrate to using difflib for the diffs in 0.9, which would fix this problem, and make a replacement of svn.fs.FileDiff.get_pipe() obsolete.

In the meantime, this problem can apparently be worked around by making sure that the diff command is on the path.

comment:14 by Christopher Lenz, 15 years ago

I think we should migrate to using difflib for the diffs in 0.9, which would fix this problem, and make a replacement of svn.fs.FileDiff.get_pipe() obsolete.

In the meantime, this problem can apparently be worked around by making sure that the diff command is on the path.

comment:15 by Christopher Lenz, 15 years ago

Status: newassigned

/me is currently working on this

comment:16 by Christopher Lenz, 15 years ago

Resolution: fixed
Status: assignedclosed

[1314] completely removes the dependency on the diff utility.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.